Chmod, chgrp, chown problème de droit

Bonjour,

J'ai un problème de droit avec un dossier ou il me faut les droits d'écriture/lecture et d'execution en simple utilisateur et avec root

En super utilisateur ça marche
[root@localhost laurent]# ls -alF /media/serveur-public  
total 24  
drwxrwx--- 2 root users 0 avril 29 21:15 ./  
drwxr-xr-x 6 root root 4096 avril 28 22:00 ../  
-rw-r--r-- 1 root root 889 avril 26 02:13 dossier-partage-reseau-public.txt  
-rw-rw---- 1 nobody users 2900 avril 28 23:31 Installer-un-partage-public.sh  
-rw-rw---- 1 nobody users 463 avril 29 16:45 supprimer-un-fichier-ou-repertoire.txt  
-rw-r----- 1 nobody users 5 avril 29 21:15 test  
-rw-rw---- 1 nobody users 1366 avril 28 22:52 windows7.txt.txt  
[root@localhost laurent]#


Par contre, en simple utilisateur ça marche pas
[laurent@localhost ~]$ ls -alF /media/serveur-public  
ls: impossible d'ouvrir le répertoire /media/serveur-public: Permission non accordée  
[laurent@localhost ~]$


Droit de /media/serveur-public
[laurent@localhost ~]$ ls -alF /media  
total 22  
drwxr-xr-x 6 root root 4096 avril 28 22:00 ./  
drwxr-xr-x 23 root root 4096 avril 30 14:01 ../  
drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/  
drwxrwx--- 2 root users 0 avril 29 21:15 serveur-public/  
[laurent@localhost ~]$

Comment je fait pour réunir le ou les utilisateurs avec root ?

j'ai des postes à 1 utilisateur et d'autre à 3 utilisateurs.
Mais dans les droits je me mélanges les pédales, je sais pas pourquoi

1/ Quels devra être la commande pour le poste à 1 utilisateur avec droit d'écriture/ lecture et d'execution avec root ?
2/ Quels devra être la commande pour le poste à 3 utilisateurs avec droit d'écriture/ lecture et d'execution avec root ?

Merci.

15 réponses

  1. Contributeur
    Bonsoir,

    Est-ce que ton compte "laurent" fait parti du groupe "users" ?
    --
    0
    1. Bonsoir,

      Merci de votre réponse

      Question
      1/ Comment fait on pour voir tout les groupes qui on été créé dans la bécane
      2 / pour ajouter laurent a un groupe (dans l'exemple groupe users) esce comme ceci :
      # usermod -G users laurent

      Merci.
      0
      1. Contributeur
        1/ cat /etc/group
        2/ usermod -a -G users laurent

        --
        0
        1. Je ne comprend pas pourquoi il ne veut pas changer le propriétaire du dossier "/media/serveur-public"
          Je doit mal mis prendre ?

          Commande effectué
          [root@localhost laurent]# ls -l /media  
          total 16  
          drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/  
          drwxrwx--- 2 root users 0 avril 29 21:15 serveur-public/  
          [root@localhost laurent]#  
          [root@localhost laurent]# umount /media/serveur-public  
          [root@localhost laurent]#  
          [root@localhost laurent]# chown laurent:laurent /media/serveur-public  
          [root@localhost laurent]#  
          [root@localhost laurent]# mount.cifs //192.168.0.1/public /media/serveur-public  
          Password:  
          [root@localhost laurent]#  
          [root@localhost laurent]# ls -l /media  
          total 16  
          drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/  
          drwxrwx--- 2 root users 0 avril 29 21:15 serveur-public/  
          [root@localhost laurent]#


          Groupe users
          [root@localhost laurent]# cat /etc/group | grep users
          users:x:100:
          vboxusers:x:417:
          [root@localhost laurent]#


          Groupe laurent

          [root@localhost laurent]# cat /etc/group | grep laurent
          laurent:x:500:
          [root@localhost laurent]#


          Merci.
          0
          1. Contributeur
            c'est sur ton partage que les droits ne sont pas bon. sur le serveur 198.168.0.1

            --
            0
            1. Bonjour,

              contenue du fichier /etc/fstab du serveur 192.168.0.1
              root@debian:~# cat /etc/samba/smb.conf  
              [global]  
              server string = DreamPlug Debian serveur 
              workgroup = Z1  
              netbios name = Serveur  
              public = yes  
              encrypt passwords = true  
              security=user  
              usershare allow guests = yes  
              map to guest = bad user  
              
              # Ajout d'un partage "public" en accès lecture/écriture sans login :  
              [public]  
                 path = /home/serveur/Public  
                 comment = partage public  
                 writeable = yes  
                 force user = nobody  
                 force group = users  
                 create mode = 660  
                 public = yes  
                 directory mode = 771  
              
              # Ajout d'un partage "www" en accès lecture/écriture sans login :  
              [www]  
                 path = /var/www  
                 comment = site web  
                 available = yes  
                 browseable = yes  
                 public = yes  
                 writable = yes  
              
              root@debian:~# 


              Dans ce cas la comment je peut faire ?

              Merci.
              0
              1. Donc ca provient de la ?
                Ce qui veut dire que l'on ne peut pas modifier le propriétaire depuis un poste.
                la seul est unique solution est de :

                1/ rajouter les utilisateurs au groupe "users" sur chaque poste.
                # usermod -G users "utilisateur"
                2/ soit d'ajouter les utilisateurs sur le serveur
                # useradd  nom_de_l'utilisateur

                Utilisateur du groupe "users" du serveur
                root@debian:~# cat /etc/group | grep users 
                users:x:100: 
                root@debian:~#


                Quand pensez vous, a moins que je ra compte des bêtises ?

                Merci.
                0
                1. bonsoir,

                  J'ai fait :
                  [root@localhost laurent]# ls -l /media 
                  total 16 
                  drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/ 
                  drwxrwx--- 2 root users 0 avril 29 21:15 serveur-public/ 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# umount /media/serveur-public 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# usermod -G users laurent 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# id laurent 
                  uid=500(laurent) gid=500(laurent) groupes=500(laurent),100(users) 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# mount.cifs //192.168.0.1/public /media/serveur-public -o username="guest" 
                  Password: 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# ls -l /media 
                  total 16 
                  drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/ 
                  drwxrwx--- 2 root users 0 avril 29 21:15 serveur-public/ 
                  [root@localhost laurent]# 
                  
                  [laurent@localhost ~]$ ls /media/serveur-public 
                  ls: impossible d'ouvrir le répertoire /media/serveur-public: Permission non accordée 
                  [laurent@localhost ~]$ 
                  [laurent@localhost ~]$ su 
                  Mot de passe : 
                  [root@localhost laurent]# 
                  [root@localhost laurent]# umount /media/serveur-public 
                  [root@localhost laurent]# chown laurent:laurent /media/serveur-public 
                  [root@localhost laurent]# ls -l /media 
                  total 20 
                  drwxr-xr-x 2 root root 4096 avril 26 23:07 cdrom/ 
                  drwxrwx--x 2 laurent laurent 4096 avril 28 14:22 serveur-public/ 
                  [root@localhost laurent]# exit 
                  exit 
                  [laurent@localhost ~]$ su 
                  Mot de passe : 
                  [root@localhost laurent]# mount.cifs //192.168.0.1/public /media/serveur-public -o username="guest" 
                  Password: 
                  [root@localhost laurent]# exit 
                  exit 
                  [laurent@localhost ~]$ ls /media/serveur-public 
                  ls: impossible d'ouvrir le répertoire /media/serveur-public: Permission non accordée 
                  [laurent@localhost ~]$ 
                  
                  

                  je sais plus quoi faire ???????????

                  Merci.
                  0
                  1. Contributeur
                    Il faudrait regarder du côté des logs SAMBA de la machine serveur.
                    0
                2. bonjour,

                  Sur le serveur debian squeeze
                  /var/log/samba/log.smbd (le fichier est trop long pour tout mettre)

                  le logs de SAMBA
                  [2012/05/02 00:19:50.990876,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 00:23:07.927188,  1] smbd/service.c:1251(close_cnum) 
                    __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public 
                  [2012/05/02 09:17:57.190360,  1] smbd/service.c:1070(make_connection_snum) 
                    __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4971) 
                  [2012/05/02 09:20:57.193763,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 09:20:57.210842,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 09:33:57.513861,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 09:33:57.530928,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 09:46:57.893712,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused 
                  [2012/05/02 09:46:57.910919,  0] printing/print_cups.c:108(cups_connect) 
                    Unable to connect to CUPS server localhost:631 - Connection refused


                  Merci.
                  0
                  1. Contributeur
                    Il n'y a pas un fichier de log avec le nom ou l'adresse IP de la machine qui monte le partage ?
                    0
                3. Bonjour,

                  Sur le serveur, dans "/var/log/" et "/var/log/samba/", il n'y a dans aucun fichier log, le nom ou l'adresse IP de la machine qui monte le partage, qui est le serveur ?

                  Merci.
                  0
                  1. Contributeur
                    Re,

                    l'information devrait se trouver dans le fichier de log de type :
                    /var/log/samba/log.[nom ou adresse ip du serveur]


                    Il devrait y avoir des lignes concernant les connexions depuis le poste client.
                    0
                4. Voila le log du poste client

                  /var/log/samba/log.nmbd
                  [2012/05/01 01:42:26.123294,  0] nmbd/nmbd.c:71(terminate)
                  Got SIGTERM: going down...
                  [2012/05/01 08:12:54,  0] nmbd/nmbd.c:857(main)
                    nmbd version 3.5.8 started.
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/01 08:12:54.793388,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 08:12:54.793460,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 08:12:54.809727,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 08:12:54.809753,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 22:05:00.561081,  0] nmbd/nmbd.c:71(terminate)
                    Got SIGTERM: going down...
                  [2012/05/01 22:06:45,  0] nmbd/nmbd.c:857(main)
                    nmbd version 3.5.8 started.
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/01 22:06:45.532677,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 22:06:45.532735,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 22:06:45.548468,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 22:06:45.548491,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/02 00:23:01.491370,  0] nmbd/nmbd.c:71(terminate)
                    Got SIGTERM: going down...
                  [2012/05/02 09:17:55,  0] nmbd/nmbd.c:857(main)
                    nmbd version 3.5.8 started.
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/02 09:17:55.500094,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/02 09:17:55.500144,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/02 09:17:55.521888,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/02 09:17:55.521915,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"


                  /var/log/samba/log.smbd
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/01 08:12:45.039572,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 08:12:45.039618,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 08:12:45.151233,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 08:12:45.151254,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 08:12:47.512654,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/01 08:12:50.425894,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/01 08:12:54.793947,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée
                  [2012/05/01 08:12:54.794110,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée
                  [2012/05/01 08:18:26.667730,  0] lib/util_sock.c:474(read_fd_with_timeout)
                  [2012/05/01 08:18:26.667853,  0] lib/util_sock.c:1441(get_peer_addr_internal)
                    getpeername failed. Error was Noeud final de transport n'est pas connecté
                    read_fd_with_timeout: client 0.0.0.0 read error = Connexion ré-initialisée par le correspondant.
                  [2012/05/01 22:06:41,  0] smbd/server.c:1119(main)
                    smbd version 3.5.8 started.
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/01 22:06:41.818107,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 22:06:41.818166,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 22:06:41.868060,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/01 22:06:41.868081,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/01 22:06:43.528787,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/01 22:06:43.531630,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/01 22:06:46.022978,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée
                  [2012/05/01 22:06:46.023181,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée
                  [2012/05/02 09:17:50,  0] smbd/server.c:1119(main)
                    smbd version 3.5.8 started.
                    Copyright Andrew Tridgell and the Samba Team 1992-2010
                  [2012/05/02 09:17:50.445820,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/02 09:17:50.445881,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/02 09:17:50.496718,  1] param/loadparm.c:6494(map_parameter)
                    Unknown parameter encountered: "encrypt password"
                  [2012/05/02 09:17:50.496748,  0] param/loadparm.c:7588(lp_do_parameter)
                    Ignoring unknown parameter "encrypt password"
                  [2012/05/02 09:17:50.812367,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/02 09:17:51.112185,  0] printing/print_cups.c:108(cups_connect)
                    Unable to connect to CUPS server localhost:631 - Connexion refusée
                  [2012/05/02 09:17:55.506478,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée
                  [2012/05/02 09:17:55.506683,  0] smbd/server.c:500(smbd_open_one_socket)
                    smbd_open_once_socket: open_socket_in: Adresse déjà utilisée


                  Tout les autres fichiers contenu dans /var/log/samba/ sont vide.

                  Merci.
                  0
                  1. Contributeur
                    Que retourne la commande suivante sur le serveur samba :
                    smbstatus
                    0
                5. Bonjour,

                  Sur le poste client la commande suivante retourne :
                  [root@localhost serveur-public]# smbstatus 
                  Unknown parameter encountered: "encrypt password" 
                  Ignoring unknown parameter "encrypt password" 
                  Unknown parameter encountered: "encrypt password" 
                  Ignoring unknown parameter "encrypt password" 
                  
                  Samba version 3.5.8 
                  PID     Username      Group         Machine 
                  ------------------------------------------------------------------- 
                  
                  Service      pid     machine       Connected at 
                  ------------------------------------------------------- 
                  
                  No locked files 
                  
                  [root@localhost serveur-public]# 
                  


                  Sur le serveur la commande suivante retourne :
                  root@debian:~# smbstatus 
                  
                  Samba version 3.5.6 
                  PID     Username      Group         Machine 
                  ------------------------------------------------------------------- 
                  
                  Service      pid     machine       Connected at 
                  ------------------------------------------------------- 
                  public       4971   __ffff_192.168.0.2  Wed May  2 09:17:57 2012 
                  
                  No locked files 
                  
                  root@debian:~# 
                  


                  Merci.
                  0
                  1. Contributeur
                    Sur le serveur, que retourne la commande suivante :
                    grep 192.168.0.2 /var/log/samba/*
                    0
                6. Bonsoir,

                  Voila le resultat
                  root@debian:~# grep 192.168.0.2 /var/log/samba/*
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2762)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2763)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2776)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2777)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2782)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service www initially as user nobody (uid=65534, gid=65534) (pid 2793)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2794)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2795)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service www
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2809)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2810)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2811)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2812)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2813)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2814)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2887)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2903)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2912)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2950)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service www initially as user nobody (uid=65534, gid=65534) (pid 2951)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service www initially as user nobody (uid=65534, gid=65534) (pid 2952)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service www
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2966)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 2976)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service www initially as user nobody (uid=65534, gid=65534) (pid 2977)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service www
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service www
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3004)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3005)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3012)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3405)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3418)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3427)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3428)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3773)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3777)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3781)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3792)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3814)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3818)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 3822)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4083)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4094)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service www initially as user nobody (uid=65534, gid=65534) (pid 4259)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4260)
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service www
                  /var/log/samba/log.smbd:  mageia (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4505)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4506)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4582)
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) closed connection to service public
                  /var/log/samba/log.smbd:  __ffff_192.168.0.2 (::ffff:192.168.0.2) connect to service public initially as user nobody (uid=65534, gid=100) (pid 4971)
                  root@debian:~#
                  
                  0
                  1. Contributeur
                    Le problème semble venir de l'option " force user = nobody" du partage public :
                    [public]  
                       path = /home/serveur/Public  
                       comment = partage public  
                       writeable = yes  
                       force user = nobody  
                       force group = users  
                       create mode = 660  
                       public = yes  
                       directory mode = 771  
                    


                    Pourquoi avoir choisi ce paramètre ?
                    --
                    0
                    1. Bonsoir,

                      Je n'ai pas de raison special, me conseillez vous de le supprimer.

                      Merci.
                      0
                      1. Contributeur
                        C'est ce qui fixe l'utilisateur malgré le fait de rajouter l'option user= dans la commande du client.
                        Ce que confirme les logs du serveur.
                        0