Fonction NB.SI sur open office [Résolu/Fermé]

Signaler
Messages postés
25
Date d'inscription
jeudi 29 janvier 2009
Statut
Membre
Dernière intervention
11 juin 2013
-
Messages postés
25
Date d'inscription
jeudi 29 janvier 2009
Statut
Membre
Dernière intervention
11 juin 2013
-
Bonjour !

Voilà, j'ai un soucis, que j'ai réussis à contourner, mais la manière utilisée me prends énormément de temps, aussi je viens vers vous pour essayer de trouver une solution plus rapide!

En fait je travail en ce moment sur un tableur concernant le profil de gens croisés sur le chemin de Compostelle, et j'aimerais en tirer des moyenne, essayer de déterminer des profils type s'il y en a, etc. Pour ça j'aimerais pouvoir utiliser des fonctions me permettant de regrouper plusieurs "tri", comme par exemple pour calculer la moyenne de kilomètres parcourus à pieds par les hommes ayant la quarantaine. J'aimerais savoir si une fonction du genre =Moyenne(kilomètres parcourus SI (locomotion="pieds")ET(age="entre 40 et 49") existait ?
Je dois dire que j'ai essayé tout plein de formulation, j'ai essayé de bidouiller celles que je connaissais déjà, mais en vain ...

Donc si vous saviez quoi que ce soit qui pourrais m'aider, je vous en serez fort reconnaissant !!! :)

Merci d'avance,

Loup

PS : Pour info, je dois avoir la dernière version de open office il me semble.



4 réponses

Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bonjour

on peut proposer si vous avez un champ age et un champ Moyen:

=SOMMEPROD((champ moyen="moyen")*(champ age >=age mini)*(champ age=<Axe maxi))

Vous pouvez placer à la place de "moyen" . age mini ou age maxi les adresses de cellules où vous placerez les textes ou valeurs.

directement dans les formules, mettez les textes cherchés entre guillemets et pour le code SOMMEPROD, indiquer obligatoirement les débuts et fin de champ
exemple (A:A="moyen") ne fonctionne pas il faut préciser (A1:A1000="moyen), donc avec les n° de ligne.

crdlmnt
Messages postés
25
Date d'inscription
jeudi 29 janvier 2009
Statut
Membre
Dernière intervention
11 juin 2013
1
Bonjour,

Tout d'abord, merci pour votre réponse très rapide !
Alors, voici la formule telle que je l'utilise :
=SOMMEPROD((KmJour>=X239)*(KmJour<=Y239)*(Age>=T245)*(Age<=U245)*(Mode="Pieds"))

Elle fonctionne parfaitement bien, en revanche me vient un autre soucis.

C'est quand j'essaye de faire, par exemple : La moyenne du poids des hommes entre 0 et 20 ans. J'ai donc la formule :
=SOMMEPROD((Poids)*(Age>=H256)*(Age<=I256)*(Sexe="M"))
Vous l'auriez surement deviné, mais comme dit plus haut par Vaucluse, H256 et I256 correspondent respectivement à des valeurs de 0 et 20. J'ai de plus deux plages pour le sexe des gens et leurs poids, nommées sans surprise "Sexe" et "Poids". :)

Ceci me donne la somme des poids des gens entre 0 et 20 ans, de sexe masculin. Comment faire pour obtenir la moyenne de ceci ?

Merci encore Vaucluse, tu m'as tiré d'un bien grand désarrois en tout cas !

Et merci d'avance à ceux qui auront une solution pour mon problème que je n'arrive pas à résoudre !

Bon week ends,

Loup
Messages postés
26108
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 juillet 2021
5 993
Bonjour et pas de quoi:
essayez celle-ci
=SOMMEPROD((Poids)*(Age>=H256)*(Age<=I256)*(Sexe="M"))/SOMMEPROD((Age>=H256)*(Age<=I256)*(Sexe="M"))
sachant que lorsque vous retirer de SOMMEPROD l'item ou se fait la somme, vous compter le nombre de types dans les conditions

crdlmnt
Messages postés
25
Date d'inscription
jeudi 29 janvier 2009
Statut
Membre
Dernière intervention
11 juin 2013
1
Bonjour,

Désolé de répondre si tard, mais j'ai été coupé d'internet pendant quasiment deux semaines ... Heureusement que j'avais la "première" formule, sinon j'aurais pété un câble de prendre tant de retard !!

Je viens d'essayer votre formule, et en effet elle fonctionne à merveille !!! Merci encore de m'avoir tiré si vite des soucis dans lesquels j'étais empêtrés depuis un bon bout de temps !

Je reviendrais ici quand j'aurais un soucis que je n'arriverais pas à résoudre tout seul :)

Bonne journée à vous,

Loup