Aligner deux collones de chiffres sous excel [Résolu/Fermé]

Signaler
-
 dur dur -
Bonjour a tous,
J'ai un problème sous excel 2003. Je possède deux classeur excel (un de 1000 lignes et l'autre 14000)(ce sont en fait des gènes). Or je souhaite ressortir les informations de l'un pour les mettre dans l'autre. Pour cela j'ai l'identifiant de chacun des gènes (c'est un chiffre qui va de 3000 à 130000). Donc je colle la colonne contenant cet identifiant du premier classeur vers le deuxième. Mais comme le premier ne contient que 1000 lignes je doit l'aligner à la main avec l'idenfiant du deuxième ce qui est extremement long. N'y a t'il pas un moyen automatique d'aligner deux colonnes de nombre pour que les nombre égaux ce retrouve l'un à côté de l'autre?
D'avance un grand merci


3 réponses

pour que ce soit plus clair je part de ça (mais avec 1200 lignes à gauche et 14000 à droite):
1
2 2
4 3
6 4
5
6
7

et je veut obtenir ça:
1
2 2
3
4 4
5
6 6
7
Messages postés
25291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
18 septembre 2020
5 467
Bonjour
automatique je ne sais pas , mais avec une formule oui.
exemple à adapter
Copier votre "petit champ" dans le classeur du grand, mettons pour l'exemple de X1 à X13000
il suffit alors de détecter si le code du grand champ se trouve dans le petit et le tour est joué:
de A1 à A1000 votre"petit" champ
de X1 à X13000 votre "grand" champ
formule en B1 à tirer sur la hauteur du champ:
=SI(NB.SI($X$1;$X$13000;A1);A1;"")
Pour entrer rapidement une formule sur 1000 (ou plus bien sur) lignes en B
sélectionner la case adresse à gauche de la barre de formule
inscrivez y: B1:B1000
le champ est sélectionné.
Tapez dans la barre de formule la formule correspondante à la 1° cellule du champ (ici B1)
et faite ENTREE en maintenant la touche ctrl enfoncée.
La formule se place sur toute la hauteur et s'ajuste correctement si vous avez bien mis les signes $ aux bons endroit.
Vous pouvez ensuite sélectionner la colonne B et faire un Copier / collage spécial valeur pour éliminer les formules en gardant les résultats.
crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
ça marche au poil un grand merci vous venez de me sauver 1 semaine de stage!!!