Remplacer une valeur par une cellule - Excel [Résolu/Fermé]

Signaler
-
 cgcg13 -
Bonjour,

Je n'arrive pas à trouver après de nombreux essais. J'ai un tableau avec un en-ête pour chaque colonne. Dans les colonnes, il y a "1" ou "0" ou rien. je voudrais remplacer tous les "1" par ce qui se trouve dans l'en-tête de la colonne. [par exemple toutes les cellules contenant "1" dans ma colonne A doivent avoir "le jeudi de 8h00 à 9h00" qui est l'intitulé de la colonne A (j'ai beaucoup de colonnes)
J'ai essayé les fonctions "SI" et "SUBSTITUTE" mais je n'y arrive pas.

Quelqu'un peut-il m'aider s'il vous plait
MERCI

3 réponses

Messages postés
808
Date d'inscription
samedi 22 octobre 2011
Statut
Membre
Dernière intervention
13 janvier 2020
40
Bonjour,

Il faut rajouter une colonne,
et en B2 (nouvelle colonne) tu met la formule
=SI(A2=1;$A$1;A2)

Cordialement,
Messages postés
15736
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
18 avril 2021
1 483
Bonjour,
Excel 2007
Mise en forme conditionnelle.

Pour la colonne A:
Selectionnez toutes les cellules utiles.
Menu Mise en Forme Conditionnel.
Nouvelle regle
Utiliser une formule......
formule a ecrire: =A2=1

format:
----->personnalise
--------------->Type: "le jeudi de 8h00 à 9h00"

Valider le tout

Faire pour toutes les colonnes idem en prenant le titre des colonnes
Merci, je vais donc devoir dédoubler toutes mes colonnes pour la solution de Lentzouille2 en essayant de ne pas me tromper de formule (j'ai 75 colonnes !!) ni de colonne pour mon publipostage derrière. j'espérais l'éviter..
f894009, ta solution ne marchera pas pour moi, il y a beaucoup trop de cellules éparpillées à sélectionner et changer le "type" à chaque fois serait trop long.
Merci à vous 2