[Excel/VBA] Problème de saisie d'une formule [Résolu/Fermé]

Signaler
-
 Vod -
Bonjour,
J'ai besoin qu'une macro saisisse une formule.
La formule à saisir est du type : =SI(B1<>0;((A1-B1)/B1)*100;)
La formule fonctionne quand je la saisi manuellement, mais quand je veux faire un truc du style : Range("D1").Value = "=SI(B1<>0;((A1-B1)/B1)*100;)" j'obtiens erreur 1004 erreur définie par l'application ou par l'objet.
J'ai essayé Formula ou FomulaR1C1 à la place de Value mais c'est la même chose

Je ne comprend pas trop pourquoi, la même chose sans "=" ne créer pas d'erreur. Quelqu'un a une idée ?

2 réponses

Messages postés
8700
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
22 janvier 2020
1 099
Bonjour,
Avec..
    Range("D1").FormulaLocal = "=SI(B1<>0;((A1-B1)/B1)*100;)"

Ca devrait aller.
A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57458 internautes nous ont dit merci ce mois-ci

En effet, ca à l'air de fonctionner. Merci beaucoup !