[Debian]Téléchargement iso

Résolu/Fermé
Séraphin - 17 nov. 2006 à 12:57
 hmar - 9 août 2009 à 20:02
Bonjour,

J'ai téléchargé hier un iso de la debian, mais je me suis trompé, car j'ai pris la version minimale(pas d'interface graphique), et je suis pas très bon en mode console(très mauvais).

J'ai tenté de faire un init 4, sans succès, donc j'en conclus qu'il faut installer soi même une interface graphique en mode console, trop compliqué pour moi vu mes connaissances sommaires en linux.

J'ai donc recherché un téléchargement d'iso, je pense avoir trouvé ftp://ftp2.fr.debian.org/pub/debian-cd/3.1_r3/i386/iso-cd/, mais qu'est-ce que je dois télécharger là dedans ?

J'ai déjà installé plusieurs distribution, mais d'habitude, j'achète un magazine dans la presse qui fourni les cds d'install.

Merci.
A voir également:

11 réponses

Phiphi57 Messages postés 789 Date d'inscription samedi 26 février 2005 Statut Contributeur Dernière intervention 19 juillet 2009 294
18 nov. 2006 à 10:57
et tu as bien raison ;-))
j'suis sous debian depuis qques temps maintenant, et je dois dire que je ne suis pas pret de changer! :-D

bienvenue en tout cas avec cette distrib totalement communautaire...

Phiphi
3
lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 3 565
17 nov. 2006 à 13:13
Salut,

tu prends debian-31r3-i386-netinst.iso et quand tu choisi les paquets pour l'installation coche la case pour Environnement graphiques (regarde dans ce tuto http://people.via.ecp.fr/~alexis/formation-linux/packages.html )

sinon en ligne de commande (en root)
apt-get install x-window-system-core
apt-get install gnome
apt-get install kde


lami20j
1
C'est cet iso que j'ai téléchargé :)

Mais j'ai sans doute pas fait attention pour l'interface graphique.

Si j'utilise ces 3 lignes de commande, ça va donc m'installer kde et gnome, il faut rebooter ensuite ?

Ah oui autre question, j'ai déjà une distibution linux d'insatallée(donc 2 avec la debian), si je souhaite réinstaller la debian à partir de 0, y'a t-il un moyen de repérer facilement à quel système appartient telle ou telle partition ?

J'ai pas trop envie de planter l'autre.

Merci de ta réponse ;)
0
mamiemando Messages postés 32067 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 27 janvier 2023 7 535
17 nov. 2006 à 15:25
Si j'utilise ces 3 lignes de commande, ça va donc m'installer kde et gnome, il faut rebooter ensuite ?

Ce n'est pas utile mais il faudra sans doute changer le runlevel par défaut (cf /etc/inittab) pour qu'il lance l'interface graphique au démarrage. Si tu utilises KDE il suffit de taper en root :
/etc/init.d/kdm start

et d'appuyer sur ctrl alt f7...

Le serveur X

C'est le truc qui sert à dessiner des applications graphiques (des fenêtres, tout ça).

apt-get install x-window-system-core
apt-get install gnome
apt-get install kde

Moi je dirais qu'il manque un xserver-xorg
aptitude install xorg xserver-xorg xserver-xorg-core xserver-xorg-input-kbd xserver-xorg-input-mouse xserver-xorg-video-all

...j'ai mis tout pour la vidéo mais en fait tu peux ne mettre que la tienne +v4l + vga + vesa, par exemple si tu as une carte nvidia :
aptitude install xserver-xorg-video-v4l xserver-xorg-video-vesa xserver-xorg-video-vga xserver-xorg-video-nv


Le windows manager

En supposant que tu veuilles mettre KDE
aptitude install kde-core kdebase-bin kde-i18n-fr kdesktop kdm


Et pour être autonome

Tu peux directement regarder les paquets installables avec aptitude :
aptitude

(il suffit de savoir cliquer sur les menus même si c'est en mode texte).

Rechercher un paquet :
apt-cache search xorg

Rechercher un paquet installé
dpkg -l | grep xorg

Pour installer un paquet (aptitude c'est mieux en fait) :
apt-get install monpaquet
aptitude install monpaquet

Bonne chance
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Merci beaucoup de ton explication détaillée, je vais m'atteler à la tâche.

je vous redis si j'ai réussi ;)
0
Bon ben, j'ai pas réussi...

Tous les apt-get install m'ont donné droit à des messages d'erreurs, idem pour apt-cache search xorg, j'obtiens spurious 8259A interrupt: IRQ7
Incompréhensible pour moi.

Je suis également passé par aptitude en mode graphique, mais pareil tout ce que j'ai tenté a échoué.

Pour kdm start, il n'existe pas dans /etc/init.d

Il y a un inetd comme sur la redhat, mais pas de kdm.

Je crois que je vais me simplifier la tâche en tentant une réinstallation, j'attend quand même que vous me disiez si c'est ce qu'il y a de mieux à faire ;)

Je me demande si ça ne pourrait pas venir du fait que ma connexion internet n'est pas détectée ?
Lors de l'install, elle l'a bien été, mais bon, comme je sais pas du tout d'où vient le problème...

En tout cas merci !
0
lami20j Messages postés 21331 Date d'inscription jeudi 4 novembre 2004 Statut Modérateur, Contributeur sécurité Dernière intervention 30 octobre 2019 3 565
17 nov. 2006 à 20:23
Salut,

Je crois que je vais me simplifier la tâche en tentant une réinstallation, j'attend quand même que vous me disiez si c'est ce qu'il y a de mieux à faire ;)

Alors tu deviandras paresseux comme moi :-DD

Avant de faire l'installation affiche le contenu du fichier menu.lst (voilà le chemoin vers ce fichier /boot/grub/menu.lst)

Il faut essayer de démarrer ton Linux avec les options noapic et nolapic passées au kernel.

lami20j
0
Paresseux, n'exagérons pas, quoique si un petit peu quand même :-D

Vu que c'est une installation toute fraiche, autant repartir sur une meilleure base :)

Merci je vais essayer de faire ce que tu m'as dit demain, aujourd'hui, je suis complètement blasé ;)
0
Phiphi57 Messages postés 789 Date d'inscription samedi 26 février 2005 Statut Contributeur Dernière intervention 19 juillet 2009 294
18 nov. 2006 à 09:06
en meme temps, debian "sans connaitre la ligne de commande", ca reste un peu culotté ;-)

dans ce cas, mieux vaut bien s'appuyer sur de la bonne doc, comme celle proposée par lami20j que je te recommande tres fortement : a suivre pas a pas pour comprendre un peu mieux ce que tu fais...
http://people.via.ecp.fr/~alexis/formation-linux/

Phiphi
0
J'ai tout réinstallé, et tout c'est bien passé :)

Quelques détails mineurs à règler, mais c'es tout, pas de problème particulier.

J'avais vraiment dû sauter une étape lors de ma 1ère installation, car je ne me rappelle pas avoir eu le choix d'installer des logiciels.

Merci à tous pour votre aide ;)

Oui Phiphi57, je suis du genre culotté :-D
Qui ne tente rien n'a rien :)
0
in ya pas iso sur ma psp commen fait
0