Connexion ssh en script bash

Résolu/Fermé
aalex57
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
- 15 mars 2012 à 12:16
aalex57
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
- 16 mars 2012 à 13:31
Bonjour,

J'aurais besoin de votre aide avec l'utilisation d'un script bash.
Je m'explique :

Je voudrais me connecter en ssh dans un script bash, mais je sèche pour insérer le mot de passe automatiquement.

Je fais par exemple :
ssh admin@192.168.1.1 mdp
mes commandes etc...

Mais le mot de passe n'est pas pris en compte, à chaque fois je dois le réécrire et bien évidement, aucune de mes commandes ne sont prises en compte.

Je ne peux pas utiliser le système de clé privée dans mon cas.

J'espère que vous pourrez m'aider.

Merci.

4 réponses

aalex57
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
25
15 mars 2012 à 14:41
Merci à tous pour vos commentaires, mais je rencontre énormément de problème.

En fait je voudrais me connecter sur mes switchs en ssh et faire un copy running config mais j'avoue que même avec vos explications j'ai beaucoup de mal :/
2
zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 572
15 mars 2012 à 15:36
Un exemple avec "plink".

Je me connecte à ma station "192.168.10.18", sur le port "22222", avec le login "jp", le mot de passe "xxxxx" et j'exécute la commande "hostname"

$ plink 192.168.10.18 -P 22222 -l jp -pw xxxxx hostname
MDKx86_64

$
0
aalex57
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
25
15 mars 2012 à 15:55
Voici ma commande dans mon fichier bash :

#!/bin/bash
plink 192.168.1.254 -P 22 -l admin -pw MDP hostname


J'ai auparvant installé le paquet plink avec apt-get install plink.

et lorsque je lance le script, le terminal me retourne :

./backup_test.sh: ligne 3: plink : commande introuvable


Je ne comprend pas :/
0
zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 572
15 mars 2012 à 16:24
Est-ce que depuis ton terminal la connexion au switch se fait bien avec plink ?
0
aalex57
Messages postés
91
Date d'inscription
dimanche 2 mars 2008
Statut
Membre
Dernière intervention
23 mars 2012
25
15 mars 2012 à 16:35
Euh non, je m'y connecte via ssh :/
0
zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 572
15 mars 2012 à 16:38
Depuis ton terminal, tape :

plink 192.168.1.254 -P 22 -l admin -pw MDP hostname

Et dis-nous ce qu'il en est ;-\
0
_Tawal_
Messages postés
644
Date d'inscription
jeudi 23 février 2012
Statut
Membre
Dernière intervention
7 juillet 2012
73
15 mars 2012 à 12:30
Tu peux essayer l'option -a

ssh -a admin@192.168.1.1
0
jeanbi
Messages postés
14751
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
14 août 2022
2 389
15 mars 2012 à 12:50
bonjour,
peut etre avec cette solution
https://doc.fedora-fr.org/wiki/SSH_:_Authentification_par_cl%c3%a9
a+
0
zipe31
Messages postés
36317
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
27 janvier 2021
6 572
15 mars 2012 à 13:09
Salut,

La solution passe par Expect :

http://www.oreilly.com/catalog/expect/chapter/ch03.html
http://www.cotse.com/dlf/man/expect/index.htm

Un exemple ici.

Ou avec "plink" qui fait partie des "putty-tools".

La seconde solution est la plus simple, vu que le login et password sont fournis sur la ligne de commande ;-))
0