Excel : occurrence sur pls feuilles

Résolu/Fermé
Signaler
-
 Manouchette -
Bonjour,

J'ai crée un outil de gestion dans Excel et je sèche sur une seule formule alors que l'outil est terminé.

J'ai une feuille récap des stats + 35 feuilles identiques numérotées de 1 à 35 dans lesquelles j'entre des info sur mes commandes.

Dans chacune de mes feuilles de commande il existe une et une seule cellule qui ne permet d'écrire que deux valeurs texte "M" ou "HM" et rien d'autre. Disons que c'est la cellule A1

Exemple :
Feuille 1 cellule A1 M
Feuille 2 cellule A1 M
Feuille 3 cellule A1 M
Feuille 4 cellule A1 HM
...
Feuille Stat il me faut une formule capable de me dire qu'il y a 3 "M" (total des M de toutes les cellules A1 des feuilles 1 à 35)
Feuille Stat il me faut une formule capable de me dire qu'il y a 1 HM
(total des HM de toutes les cellules A1 des feuilles 1 à 35)

J'espère que c'est assez clair pour que vous puissiez m'aider. Je ne connais rien aux macros et les personnes amenées à se servir de cet outil non plus donc il me faut une simple formule sinon je laisse tomber cette info car l'outil est déjà blindés de formules protégées.

Merci de votre aide ! et très bonne journée à tous !

Manouchette.




4 réponses

Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
888
Salut le forum

Sans cellule intermédiaire

Feuilles nommées feuil1 à feuil35
=SOMMEPROD(NB.SI(INDIRECT("Feuil"&LIGNE(1:35)&"!A1");"M"))

Feuilles nommées 1 à 35
=SOMMEPROD(NB.SI(INDIRECT(LIGNE(1:35)&"!A1");"M"))

Mytå
Quelle prétention de prétendre que l'informatique est récente
Adam et Eve avaient déjà un Apple ! [MsProject 2003(FR), Excel 2003-2007(FR)]
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 364
Bonjour,

il y a certainement plus simple mais cela fonctionne :

https://www.cjoint.com/?BCisrrADHHj

A+

pépé
Messages postés
55037
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 novembre 2021
16 974
Autre procédé, toujours sans macro :

Tu cherches une cellule vide, en dehors de la zone où tu saisis tes données et tes formules, par exemple Z98.
Tu sélectionnes tes 35 feuilles (clic sur le premier onglet, touche MAJ enfoncée et clic sur le 35ème onglet) et en Z98 tu saisis la formule
=SI(A1="M";1;0) ; de même en Z99 tu saisis =SI(A1="HM";1;0) ;
tu vas dans la feuille Stat et tu saisis dans une cellule
=SOMME(Feuil1:Feuil35!Z98), dans une autre =SOMME(Feuil1:Feuil35!Z99).

Salut à vous deux.
Merci à tous ! cela m'a beaucoup aidé !