Excel addition des heures négatives???

[Résolu/Fermé]
Signaler
-
Messages postés
23763
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
-
Bonjour,

J'ai un tableau excel (office 2010) pour du timbrage qui fonctionne parfaitement seulement cela pêche quand il faut addtionner des heures négatives.... :(
Ex: -16:50 (format de la cellule [h]:mm:ss) correspondant au mois de janvier.
2:30 idem format de cellule
#VALEUR!

J'ai essayer de cocher le calendrier 1904 comme lu mais rien n'y fait...

Salutations

4 réponses

bien sûr que si !
=SI(A1>A2;"-";"")&TEXTE(ABS(A2-A1);"hh:mm")
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
23763
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
3 115
Salut,

excel ne sait pas gérer les heures négatives...
Messages postés
54683
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
16 593
Bien sûr que non, buzz !
Transformer une valeur numérique en texte n'est pas ce qu'on peut appeler "gérer des heures négatives" ...
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 894
Bonjour à tous,

Pas d'accord raymond.
Excel sait gérer les heures négatives, les résultats sont parfaitement bons et exploitables.
Il ne sait pas les afficher correctement, c'est tout.
D'où cette possibilité d'une colonne supplémentaire pour l'affichage.

eric
Messages postés
54683
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
16 593
Salut BS.

Je te déconseille de changer de calendrier ; tu risques de rencontrer des problèmes dans tes autres fichiers ! La solution, toute simple, est de placer tes heures "positives" dans une colonne et les autres dans la colonne voisine.
https://www.cjoint.com/c/EAxaCn1ujOY

Cordialement.
Messages postés
23763
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
3 115
Salut,

message initial datant de 3 ans...