Excel 2007 Créer base de données avec texte [Résolu/Fermé]

Signaler
-
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
-
Bonjour,

J'aimerai configurer une base de données avec du texte. Pour être plus précis, je voudrai que le texte dans chaque colonnes soit filtré et calculer sur une autre page du même classeur.

Certains mots représenteront des actions. Juste un exemple pourrait être une victoire (ajouter 2 points à la cellule sélectionné) et une défaite (retirer 3 points à la cellule sélectionné).

Si quelqu'un peut m'éclairer ce serait apprécié.

Merci



3 réponses

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 279
Bonjour,

Ta formule est fausse :

=SI(P:P="gagne";1;"")

le texte doit toujours être mis entre guillemets, les valeurs numériques sans guillemets. les doubles guillemets indiquent qu'il ne faut rien mettre.

Syntaxe générale :

=SI(Condition;vrai; faux)
si la condition est vérifiée alors faire ceci sinon faire cela

le plus simple serait de renvoyer un exemple de ton fichier via cijoint.com

A+

pépé
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61028 internautes nous ont dit merci ce mois-ci

OK maintenant ca l'air de bien fonctionné. J'essayais plein d'affaires mais la solution était dans mes guillemets. Je sait pas pourquoi je faisait toujours Shift+Virgule 2x pour me donner des guillemets mais cela n'avait pas l'air de fonctionné. J'ai ensuite copier/coller tes guillemets de ton texte et voila ca fonctionne. Maintenant il me reste à trouver le raccourcis des guillemets et je peut m'attaquer à mon projet

Merci de ton temps et de ta patience! Cela est très apprécié (:
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 279
Bonjour,

A côté de ta colonne à tester, je rajouterais une colonne avec la formule suivante :

=SI(A2="Victoire";2;SI(A2="Défaite";-3;""))

cela donnerait 2 pour une victoire et -3 pour une défaite, rien si la cellule est vide.

Ensuite, il suffit d'intégrer dans tes autres feuilles le résultat obtenu.

A+

pépé
Voila,

Ma colonne contiendra beaucoup de doublons et j'aimerai que chaque texte vaut 1. Ce que je n'arrive pas à comprendre c'est comment faire pour accumulé le texte de chaque lignes pour avoir un total. J'ai utilisé =SI(P:P=gagne;''1'';) mais sans succès. La cellule reste à 1 comme quoi il ignore les doublons... ou je ne sait pas.

Merci de ta réponse
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 279
Bonsoir,

les guillemets se trouvent sur la première rangée de touches du clavier alpha avec le 3 et le dièse (en minuscule). C'est la même touche pour ouvrir et fermer les guillemets.

A+

pépé