NB.SI Matricielle en Excel 2007 - SOS

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
vendredi 3 février 2012
Statut
Membre
Dernière intervention
14 mars 2012
-
Messages postés
3
Date d'inscription
vendredi 3 février 2012
Statut
Membre
Dernière intervention
14 mars 2012
-
Bonjour,

Voilà des heures que j'essaie de trouver la formule qui m'aiderait, mais je n'y arrive pas. Qui pourrait m'aider?

Soit le tableau suivant, indiquant des notes attribuées par des réviseurs à des traducteurs pour des textes différents (dans cet exemple, 8 textes ont été révisés par 3 réviseurs; dans la vraie vie, on parle de quelques centaines de textes révisés par une quinzaine de réviseurs, alors j'ai vraiment besoin de la formule!) :

Réviseur Note

Alain B
Jean C
Pierre C
Pierre B
Alain A
Pierre C
Jean C
Jean A

Je veux savoir « Combien de C Jean a-t-il attribué? » La réponse est 2. Quelle est la formule?

Je pensais avoir trouvé la réponse ici :

https://support.microsoft.com/fr-fr/office/compter-le-nombre-d-occurrences-d-une-valeur-aa1f3067-05c9-44e4-b141-f75bb9bb89bd?ocmsassetid=hp010070480&correlationid=27bedce8-f9da-4d24-aa1f-30da647ac25e&ui=fr-fr&rs=fr-fr&ad=fr

mais dans la formule =NB(SI((A2:A11="Sud")*(C2:C11="Viande"),D2:D11)) citée à cette page, je ne vois pas ce que vient faire le paramètre "D2:D11" (colonne « Ventes »). Je ne sais pas quoi mettre à cet endroit pour mes besoins. Et si je l'enlève, ça ne marche pas.

N.B. : J'ai bien compris que je devais valider la formule avec Ctr-Maj-Enter, le problème n'est pas là.

J'ai passé deux heures et demie à faire des recherches et des essais... Qui peut m'aider? Merci!





1 réponse

Messages postés
17602
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
23 octobre 2021
4 786
Salut,

Pour ma part j'utiliserai cette formule, en Aà A20 par exemple tes prénom et en B1 à B20 tes lettres,

=SOMMEPROD((A1:A20="jean")*(B1:B20="C"))

mais pour pouvoir utiliser cette formule pour les divers noms et notes en C1 je mettrais une liste de validation avec tes noms en D1 une liste de validation avec tes notes

=SOMMEPROD((A1:A20=C1)*(B1:B20=D1))

Si tu as besoin d'un exemple pas de problème
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
3
Date d'inscription
vendredi 3 février 2012
Statut
Membre
Dernière intervention
14 mars 2012

Mon Dieu! C'était tellement simple, et moi qui me suis cassé la tête si longtemps! Merci, ça marche au poil!!!