Formule excel somme de 2 critères avec dates [Résolu/Fermé]

Signaler
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012
-
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012
-
Bonjour,

J'ai besoin de faire des statistiques en comptant le nombre de critères dans un critères, exemple ci-dessous.

Heure Type
A1 = 8:02 B1 = Héricourt
A2 = 10:52 B2 = Héricourt
A3 = 13:59 B3 = Aire Urbaine
A4 = 9:06 B4 = Héricourt
A5 = 8:53 B5 = Villages
A6 = 8:41 B6 = Héricourt

Voici mon tableau récap qui dois me donner le nombre pour chaque type par tranche d'horaire.

Type 8:00-9:00 9:00-10:00 10:00-11:00
Héricourt x x x
Aire Urbaine x x x
Villages x x x

J'ai essayé la formule suivante :
=SOMMEPROD((A1:A6<"9:00")*1;(B1:B6="Héricourt")*1)
Elle m'aditionne tout ce qui contient le mot "Héricourt".


Est-ce que quelqu'un aurait la solution ??

3 réponses

Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 503
Salut,

pour la période de 10:00 à 11:00
=SOMMEPROD((A1:A6>10/24)*(A1:A6<11/24)*(B1:B6="Héricourt"))

pour la période de 9:00 à 10:00
=SOMMEPROD((A1:A6>9/24)*(A1:A6<10/24)*(B1:B6="Héricourt"))

pour la période de 8:00 à 9:00
=SOMMEPROD((A1:A6>8/24)*(A1:A6<9/24)*(B1:B6="Héricourt"))

Si c'est ce que tu cherches, je pense que tu devrais créer dans une cellule ex. D1 une liste de validation pour sélectionner le critère "Héricourt, Villages, Aire Urbain etc ..." et dans la formule à la place de saisir le critère, faire référence à cette cellule

exemple pour la tranche 10:00-11:00
=SOMMEPROD((A1:A6>10/24)*(A1:A6<11/24)*(B1:B6=D1))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

C'est parfait, Merci bcp
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

Je voudrais faire la même formule avec un nouveau critère date :
en gros, faire la somme si c'est un lundi entre 8h et 9h et qu'il est en "héricourt".
Est-ce possible ?
Messages postés
16391
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 février 2021
3 142
Bonjour

Sans se prendre la t^te en 10 minutes avec un Tableau croisé dynamique

https://www.cjoint.com/?3BdqOuBigvF
Messages postés
20
Date d'inscription
samedi 14 janvier 2012
Statut
Membre
Dernière intervention
1 mars 2012

Merci mais mike31 a déjà répondu à ma question.