Probleme sur formule excel 2007 [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012
-
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012
-
Bonjour,

Je vais essayé d'epxposé rapidement mon problème:
J'ai un tableau qui permet de calculer des heures arrivée et de départ + des heures complémentaire (tableau d'heures d'assistante maternelle). Le calcul de différence d'heure ne me pose pas de problème, c'est plutot la suite.
En fonction du résultat de la différence, je veux remplir une autre cellule qui correspond à une indemnité journalière:
=SI((H5*24+J5*24)=0;0;SI((H5*24+J5*24)<9;2.65;SI((H5*24+J5*24)>=9;SI((H5*24+J5*24)<10;2.92;3.18))))
(j'essais de joindre le fichier le plus rapidement possible)
Alors, en H5 c'est la différence entre heure de départ et heure d'arriver au format hh:mm et en J5 c'est les heure complémentaire au même format.
Je les transforme en centième d'heure pour le calcul.
Mon problème survient lorsque la somme H5 et J5 est égal à 9. SI((H5*24+J5*24)>=9, cette partie ne fonctionne pas: si le résultat est égale à 9 je dois mettre dans la cellue 2.92 alors qu'il me met 2.65. Dés que ce résultat est supérieur à 9 cela fonctionne.
Je ne comprend pas pourquoi.
Merci d'avance pour votre aide

PS: si vous connaissez un site d'hébergement rapide de fichier je suis preneur.
(Je ne serai de retour qu'en fin d'aprés midi)

Cordialement

7 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 291
Bonjour,

votre condition SI((H5*24+J5*24)>=9 est inutile, car juste avant vous testez si c'est strictement inférieur à 9. Si c'est faux, cela veut dire que c'est égal ou supérieur à 9, donc vous testez directement si c'est inférieur à 10.

Du coup votre formule devient :
=SI((H5*24+J5*24)=0;0;SI((H5*24+J5*24)<9;2.65;SI((H5*24+J5*24)<10;2.92;3.18))) 
Cordialement.
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012

Merci pour votre réponse
Je teste ça ce soir et je vous tiens au courant
Merci
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012

re bonsoir

Je viens d'essayer mais rien à faire, toujours le même problème.
Par contre, si je rentre "9:00" à la main, la formule fonctionne.
Je vous joint le fichier
http://9giga.sfr.fr/n/50-17/share/LNK39804f29934947248/

Cordialement
Messages postés
55
Date d'inscription
mardi 24 février 2009
Statut
Membre
Dernière intervention
10 février 2012
8
Bonsoir,

A priori, j'arrive au bon résultat avec la formule =SI((H5+J5)*24=0;0;SI((H5+J5)*24<9;2,65;SI((H5+J5)*24<10;2,92;3,18))) .

Dans le cas où ça ne marche pas pour toi, donne un petit complément d'info sur ton fichier (quelles cellules doivent interagir, ou est supposé arriver le résultat,...), et je testerai dedans.

Bonne soirée,

Benibis
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012

Ok merci pour ta réponse Benibis mais ça marche toujours pas.
Je me suis creusé la tête et fait d'autre essais: le problème vient que la saisie de l'heure d'arrivée et de départ est faite par liste déroulante (afin d'éviter du tapotage lol)
Mais sérieusement je ne vois pas quel différence il y a à saisir des heures manuellement ou par liste déroulante.
Je remet un lien vers un nouveau fichier avec les 2 essais en ligne 5 et ligne 7.
Les listes déroulantes sont faites à partir de données saisies à partir de la ligne 60.
Si vous pouviez m'éclairer sur ce phénomène.
Cordialement

Voici les liens:
lien 1 excel2007 : http://9giga.sfr.fr/n/50-17/share/LNK31914f29c3b95c397/
lien 2 excel2003 : http://9giga.sfr.fr/n/50-17/share/LNK82194f29c3de9b4b9/

PS: j'espère que les liens fonctionneront et que j'aurais donné assez d'info ^^
Messages postés
53152
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 janvier 2021
15 139
Explication (grâce à Formules/Audit de formules/Evaluation de formule) :
F5 = 08:45 = 0,36458333333334
G5 = 17:45 = 0,73958333333333
H5 = 0,37499999999999
(H5+J5)*24 = 8,99999999999998 et pas exactement 9 !

Ce sont les approximations des calculs de conversion horaire ...
Messages postés
53152
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 janvier 2021
15 139
Je n'ai pas trouvé la vraie solution.
Mais en attendant on peut "bricoler" en ajoutant systématiquement la fonction ARRONDI avec moins de 6 décimales. Ainsi en I5 on écrirait
=SI(H5+J5=0;0;SI(ARRONDI(H5+J5;5)<$A$1;2,65;SI(ARRONDI(H5+J5;5)<$A$2;2,92;3,18)))
Messages postés
5
Date d'inscription
mardi 31 janvier 2012
Statut
Membre
Dernière intervention
2 février 2012

Merci Raymond pour la solution de l'arrondi.
Du coup je me suis amusé à évaluer la formule en ligne 7 et cela donne pas du tout le même résultat qu'en ligne 5
Le résultat est directement arrondi : H7*24+J7*24 donne 0.375*24 + 0*24 soit 9 donc ça fonctionne.
Bon le principal est d'avoir trouver une solution, donc merci à vous tous pour votre aider.

Quand même "Mais sérieusement je ne vois pas quel différence il y a à saisir des heures manuellement ou par liste déroulante. "

Cordialement