Comparaison excel

Fermé
Signaler
Messages postés
16
Date d'inscription
lundi 23 janvier 2012
Statut
Membre
Dernière intervention
17 mai 2012
-
Messages postés
16
Date d'inscription
lundi 23 janvier 2012
Statut
Membre
Dernière intervention
17 mai 2012
-
Bonjour,

J'ai deux fichiers excel:
- 1 avec 1 000 noms associés à des montants
- L'autre avec 500 noms associés à des montants

Parmis les 1 000 noms du premier fichier, il y a les 500 noms du deuxième fichier. je dois vérifier que les montants sont les mêmes dans les 2 tableaux. Or, c'est par ordre alpha, et au milieu du premier fichier, il y en a pleins de noms qui ne sont pas dans le deuxième fichier. Donc un copier coller ne fonctionnerait pas.

Je peux véreifier ligne par linge ... mais si vous connaissez un moyen plus simple ...

J'espère avoir été claire =/

Merci d'avance !

4 réponses

Messages postés
55357
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 janvier 2022
17 223
Bonjour.

Autre méthode :
* En feuille 2 les données occupent la plage A1:C501, avec les noms en A et les montants en C. Tu définis le nom "zone" pour cette plage.
* En feuille 1, avec les noms en colonne A, tu utilises la formule
=RECHERCHEV(A2;zone;3;FAUX) que tu recopies jusqu'à la ligne 1001.
* Tu obtiens soit le message #N/A si ce nom n'existe pas en feuille 2, soit le montant cherché.
C'est bien, la retraite ! Surtout aux Antilles ... :-)
Raymond
1
Messages postés
3530
Date d'inscription
jeudi 6 août 2009
Statut
Membre
Dernière intervention
15 octobre 2021
2 023
Bonjour, avec une formule de calcul je pense qu'Excel peut trouver les doublon et copier ce qu'il manque! Je pense que tu auras besoin de morefunc sinon tu devras ouvrir tes deux fichiers pour qu'Excel travaille.

Bonne année
0
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 734
Bonjour

Avec les noms en A et les montants en B dans les 2 fichier, dans le fichier contenant le moins de noms (500), en C2 taper :
=INDEX('[Fichier1000.xls]Feuil1'!B:B;EQUIV(A2;'[Fichier1000.xls]Feuil1'!A:A;0))
et tirer jusqu'en bas
et en D2 :
=B2=C2
et tirer jusqu'en bas

Mettre un filtre : colonne D = faux pour les montants différents

NOTE : chaque nom doit être unique (pas de doublon)
0
Messages postés
16
Date d'inscription
lundi 23 janvier 2012
Statut
Membre
Dernière intervention
17 mai 2012

Bonjour,

Merci à tous pour vos réponses ! ;)

Je vais essayer tout de suite
0