Excel - Prise en compte de dates sur formule

Résolu/Fermé
Signaler
-
 Easyg -
Bonjour,
J'ai besoin qu'un message s'affiche à une échéance.
Par exemple, j'ai un effectif qui part à l'étranger pour 1 an à compter du 01/01/2012.
Je rentre les dates de contrat dans 2 cellules (date départ et date retour).
Je souhaiterais qu'un message s'affiche dans une troisième cellule, 6 mois avant l'échéance (que ce message s'affiche jusqu'à la date de retour) de son retour et qui me mette, par ex. "Fin de contrat. A remplacer" ? Il faudrait donc que la valeur du jour que nous sommes à chaque instant soit prise en compte par la formule.
Par avance, merci.


1 réponse

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 720
Avec date de fin en B1, mettre en C1 :
=SI(B1>DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())-6;JOUR(AUJOURDHUI()));"Message";"")
Bonjour et merci Patrice33740.
Toute fois, bien que cette formule me semble parfaitement cohérente, quel que soit ma date de retour (que vous appelez B1 mais que j'ai mise en F4 avec cette cellule dans la formule donc), le "Message" s'affiche systématiquement, que nous soyons à plus de 6 mois de la fin ou à moins de 6 mois de la fin...
Je ne vois pas le bug...
Je précise que j'ai mis la cellule F4 en format "Date" sous la forme jj/mm/aaaa.
Par avance, merci
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 720
dsl, il faut :
=SI(B19<DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI())+6;JOUR(AUJOURDHUI()));"Message";"")
Mille et un mercis Patrice33740 !
Cela fonctionne parfaitement bien.
Cordialement....