Couleur du texte à retirer d'une somme [Résolu/Fermé]

Signaler
-
Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
-
Bonjour, je me demandée s'il existait une formule pour retirer des horaires d'une couleur différente dans la totalitée d'une colonne
je m'explique j'ai une colonne de A1 à A30 dans chaque cellule j'ai 10,00h dont 3 cellule (A15,A20 et A23)écrit en rouge, celle ci je ne veux pas les aditionner dans la totalitée, esqu'il existe une formule pour
je travail sur exel 2010
si oui pouvais vous me la formuler en toute simplicité merci d'avance

4 réponses

Messages postés
15271
Date d'inscription
jeudi 14 juillet 2011
Statut
Contributeur
Dernière intervention
15 décembre 2020
6 249
Bonjour,
Pourquoi ne pas mettre ces chiffres spécifiques dans une colonne voisine ?
c'est un plannig horaire qui contien beaucoup de colonne diferente( heure d'arrive, depart total absence, motif, heure supp, repas etc......)
Messages postés
9677
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 février 2021
2 043
bonjour

si la couleur provient d'une MFC, c'est jouable avec une SOMME.SI ou autre, sinon, il faudra passer par une macro

bonne suite
c'est quoi une MFC, vous pouvez me donner un exemple de formule stp merci, car je ni comprend rien là pour moi c'est du chinois lol, je ne sais même pas me servir d'un macro
Messages postés
9677
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 février 2021
2 043
re

une Mise en Forme Conditionnelle est comme son nom l'indique une mise en forme (police, couleur, motif, ...) d'une cellule qui dépend d'une condition
tu trouves ça (excel 2003) dans Format/mise en forme conditionnelle
ex tu veux mettre sur A1 un fond rouge lorsque la valeur est égale à 3
1. Format/mise en forme conditionnelle
2. La valeur de la cellule est égale à 3
3. format/motif etc ...

donc si ta couleur dépend d'une MFC, tu dois pouvoir appliquer cette condition à SOMME.SI
sinon ...

bonne suite
Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
15 368
Bonjour val000.

Comme tu ne connais ni les MFC, ni les macros, et que tu veux quelque chose de simple, voici une solution :
Dans toutes les cellules en rouge, tu mets un apostrophe devant le nombre.
Ainsi, en A15 au lieu d'écrire 10,00 tu écris '10,00 et le nombre devient du texte ; par conséquent dans la formule =SOMME(A8:A17) le contenu de A15 va compter pour rien ; de même dans la formule =SOMME(A3:A22).
Tu as compris le truc ?
ca c'est pas bête merci raymond je vais essayer
Génial cela fonctionne un énorme merci Raymond PENTIER
Messages postés
53349
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 février 2021
15 368
Content de t'avoir dépanné ; à bientôt.