Affichage de résultat - Formules Excel

[Résolu/Fermé]
Signaler
Messages postés
1055
Date d'inscription
jeudi 11 octobre 2007
Statut
Membre
Dernière intervention
1 mars 2012
-
Messages postés
54877
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour à tous,

À défaut d'avoir accès aux données "temps" dans mon entreprise, j'ai voulu me créer un fichier "Pointage", où je recense mes heures d'arrivée/sortie.

La pause déjeuner ne doit pas être inférieure à 45 minutes. J'ai créé une formule qui calcule le temps écoulé entre le deuxième et le troisième badgeage (colonnes D et E), et qui m'indique une erreur dans une autre cellule (colonne L): "Attention: pause <45min!" si ce temps est inférieure à 45 minutes: [=SI(E4-D4<TEMPS(0;45;0);"<45min!!";"")]

Mon problème est le suivant.

Quand les zones horaires (colonnes D et E) ne sont pas remplies, les cellules de la colonne L affichent le message d'erreur. J'aimerais que les cellules de la colonne L soient vierge tant que la condition n'est pas vérifiée (et donc que le message ne s'affiche qu'en cas de 'problème')

Je pensais que la formule correspondait à cette logique, mais il s'avère que non. La formule inverse (si supérieure alors rien sinon message) me renvoi le même résultat en cellule L quand les cellules des colonnes D et E vides.

J'espère avoir été assez clair...

Merci de m'éclairer!

3 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 291
Bonjour,

je pense qu'en rajoutant une condition sur le fait que les cellules soient vides pourrait vous arranger :
=SI(ET(ESTVIDE(D4);ESTVIDE(E4));"";SI(E4-D4<TEMPS(0;45;0);"<45min!!";""))


Testez et revenez nous dire si ça vous convient.

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
54877
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 775
... ou encore
=SI(D4+E4=0;"";SI(E4-D4<TEMPS(0;45;0);"<45min!!";""))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
1055
Date d'inscription
jeudi 11 octobre 2007
Statut
Membre
Dernière intervention
1 mars 2012
583
Les deux fonctionnent, mon problème est résolu.
Excel signal une "incohérence" de formule, mais les tests sont positifs; j'ignorerai donc cette alerte.

Merci à tous les deux, et bonne continuation.
Messages postés
54877
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 775
Si par "incohérence" tu fais allusion au petit triangle vert en haut à gauche de la cellule, cela signifie simplement qu'en recopiant ta formule il y a parfois des données de nature différente (date, nombre, caractères, espace ...) qui sont traitées par la formule ; excel attire donc ton attention.