Combiner SOMMEPROD et NB.SI dans Excel? [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 27 décembre 2011
Statut
Membre
Dernière intervention
27 décembre 2011
-
Messages postés
2
Date d'inscription
mardi 27 décembre 2011
Statut
Membre
Dernière intervention
27 décembre 2011
-
Bonjour,

J'ai 2 colonnes, une déterminant des dates dont certaines se répètent, voire manquent, et une autre mentionnant des initiales.

J'aimerais trouver la formule qui me sortira le nombre de "YL" (initiales) pour le mois de décembre uniquement, 12 dans mon exemple, voir ici:

https://www.cx.com/mycx/share/lIUg0DBoEeGjrRICOBubSA/Test.xls

Je pensais pouvoir combiner ces deux fonctions mais ça ne donne pas tout à fait le résultat escompté.. En effet, la première me donne bien le nombre de jours mentionnés en décembre mais de ce nombre, je dois encore décompter les initiales différentes de "YL"
=SOMMEPROD((A1:A38>="01/12/11"*1)*(A1:A38<="31/12/11"*1))
=NB.SI(B1:B38;"YL")

qqun peut-il m'éclairer?..
Bonne journée,
Patrice

4 réponses

Messages postés
16391
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
24 février 2021
3 143
Bonjour

=SOMMEPROD((MOIS(A1:A38)=12)*(B1:B38="YL"))

Attention ligne 8 et 9 tes dates sont du texte !!! ce qui renvoie "valeur" à la formule

Pour les pièces jointes utilise plutôt cjoint.com ++ rapide
Michel
Messages postés
8438
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
26 février 2021
1 612
Bonjour,

Tout simplement :
=SOMMEPROD((A1:A38>="01/12/11"*1)*(A1:A38<="31/12/11"*1)*(B1:B38="YL"))
Messages postés
8438
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
26 février 2021
1 612
Oups ! (pour ne pas compter YL) :
=SOMMEPROD((A1:A38>="01/12/11"*1)*(A1:A38<="31/12/11"*1)*(B1:B38<>"YL"))
Messages postés
23898
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 février 2021
6 668
Bonjour,

=SOMMEPROD(($A$1:$A$38>="01/12/11"*1)*($A$1:$A$38<="31/12/11"*1)*($B$1:$B$38<>"YL"))

Mais tu devrais mettre en A55 la date 01/12/11 avec un format personnalisé mmmm et en formule :
=SOMMEPROD(($A$1:$A$38>=A55)*($A$1:$A$38<=FIN.MOIS(A55;0))*($B$1:$B$38<>"YL"))
ce qui te permet de recopier la formule vers le haut ou vers le bas.

eric

edit: bé y'a du monde...
Bonjour à tous :-)
Messages postés
2
Date d'inscription
mardi 27 décembre 2011
Statut
Membre
Dernière intervention
27 décembre 2011

Merci à tous pour votre aide précieuse, ça tourne nikel!!

Bonne journée