Musique en fond sonore sur site Internet

[Résolu/Fermé]
Signaler
-
 printfx000 -
Bonjour,

j'ai un site internet et j'aimerais y mettre une musique en fond sonore.
Pour cela, j'utilise la balise <embed>, ce qui me donne un truc du style:

<embed src="musique.wav" width=100 height=10 loop=false>

Ca marche très bien lorsque je suis en local, mais quand je mets ma page html et mon fichier musique.wav en ligne, on n'entend rien du tout.

Savez vous comment c'est possible ?

Merci.

5 réponses

Messages postés
5167
Date d'inscription
mardi 18 janvier 2011
Statut
Membre
Dernière intervention
23 janvier 2013
734
Vérifie que le chemin vers ton fichier musique.wav est correct ou essaie de mettre ./ devant
<embed src="./musique.wav" width=100 height=10 loop=false> 


Le rhinocéros noir d'Afrique de l'Ouest déclaré éteint ! Cherchez plus !
Mais ça n'est qu'un début, on peut faire mieux !
salut, le chemin est correct (le fichier .wav est dans le même répertoire) et ça ne marche toujours pas.
d'ailleurs, ce n'est pas un fichier .html mais un fichier .php.
Je ne pense pas que cela fasse une différence, mais je tiens quand même à le préciser.
En tout cas, ça ne fonctionne toujours pas.

Une autre idée, s'il vous plait ?

Merci.
Messages postés
5167
Date d'inscription
mardi 18 janvier 2011
Statut
Membre
Dernière intervention
23 janvier 2013
734
Si c'est important car la balise embed doit être dans du code html.
<html>  
      <head>

          
       <body>  

         <embed src="./musique.wav" width="100" height="10" loop="false">  


<?php>


Le rhinocéros noir d'Afrique de l'Ouest déclaré éteint ! Cherchez plus !
Mais ça n'est qu'un début, on peut faire mieux !
en fait ma balise n'est pas dans des balises php, mais il se trouve dans un fichier .php.

Sa a toujours son importance ou pas ?
c'est bon. Sa fonctionne. En fait, il fallait mettre la musique à la racine du site
(c'est bizarre mais quand tu la mets dans le même répertoire, ça marche pas).

Voila. Merci beaucoup.