Excel formule Somme [Résolu/Fermé]

Signaler
-
Messages postés
16220
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 octobre 2020
-
Bonjour,



voila mon problème:

Je souhaite effectuer une somme de cellules dont certaines contiennent des nombres, et d'autres peuvent contenir une cellule ne donnant pas de résultat (elles apparaissent vides)

Le problème est que la somme m'affiche valeur fausse, j'aimerais si possible qu'elle fasse la somme des quelques cellules contenant effectivement des nombres!

Merci

3 réponses

Messages postés
16220
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 octobre 2020
3 038
bonjour

si tu as =A1+B1+C1 pas ex Tu as une erreur si il y a 1 ou plusieurs textes

Par contre
=SOMME(A1:C1) ne tient pas compte de valeurs texte
si les cellules ne sont pas jointives, les séparer par des pts-virgules
=SOMME(A1;B5;K57)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60769 internautes nous ont dit merci ce mois-ci

Messages postés
2798
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
1 octobre 2020
742
Bonjour,
Je suis passé moi même par ce problème et finalement j'ai employé une petite formule conditionnelle :

données dans a1 b1 c1 somme en d1
en d1 mettre la formule SI(OU(A1>0;B1>0;C1>0);A1+B1+C1;"")

cette formule est certainement simplifiable.
Messages postés
2798
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
1 octobre 2020
742
Re:

Exact, cela marque (#valeur!) si on rentre du texte dans l'une des cellules ; dans ce cas je modifie ma formule ainsi :

SI(OU(A1>0;B1>0;C1>0);SOMME(A1;B1;C1);"")

PapyLuc51
Messages postés
16220
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 octobre 2020
3 038
je ne vois pas l'intérêt des >0 : mxtext n'a pas demandé de faire une sélection positif-négatif !!!

pourquoi faire simple quand on peut faire compliqué