Excel date d'envoi selon jour de la semaine

Résolu/Fermé
laure - 8 déc. 2011 à 10:13
 laure - 8 déc. 2011 à 11:21
Bonjour,

Je travaille sur une base de données dans laquelle j'aimerais calculer automatiquement une date d'envoi.

J'ai deux colonnes:
- colonne A : une date du type : 07/12/2011
- colonne B : la date d'envoi à calculer

Je voudrais que la date d'envoi se calcul automatiquement en fonction du jour dans la colonne A:

- si le jour est un mardi, mercredi, jeudi, vendredi ou samedi alors la date d'envoi est le jour qui précède la colonne A

- si le jour est un dimanche ou un lundi alors la date d'envoi sera le vendredi précédent

Merci





3 réponses

J'ai trouvé!

Pour ceux que ca peut intéresser.

Dans la colonne A je garde ma date de départ.

Il faut convertir la date en jour dans une colonne qu'on appelera B:
=texte("jjjj")

dans la colonne C on cherche la date d'envoi:

=SI(OU(B3="mardi";B3="mercredi";B3="jeudi";B3="vendredi");A3-1;SI(B3="dimanche";A3-2;A3-3))
0
g
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
573
8 déc. 2011 à 11:18
Bonjour,

B2=SI(JOURSEM(A2;2)=1;A2-3;SI(JOURSEM(A2;2)=7;A2-2;A2-1))

au format date et à dérouler.

Bonne journée.
0
Merci c'est encore plus simple!

Bonne journée
0