Open Office, recherche valeur correspondante [Résolu/Fermé]

Signaler
-
 Mamouny -
Bonjour,






Voilà mon problème : Y a-t-il une fonction qui permette de simplifier l'accumulation de formules du type : (formules écrites colonne A)
=SI(B1=1;D1;A2)
=SI(B1=2;D2;A3)
=SI(B1=3;D3;A4)

Etc, etc, etc.... jusqu'à... A49204 !!!!

Le but étant par exemple : colonne C : liste de prix (ronds pour cet exemple) ; colonne D : liste d'articles ; cellule B1 : recherche d'un article par son prix.

Merci, car Open Office ne semble pas supporter les fichiers trop gros... (ma pemiere tentative était un classeur de 250 colonnes sur 49204 lignes, et il a commencé à planter vers 8 Mo, et n'a plus rien voulu savoir à 16 Mo... j'étais loin d'avoir fini) donc si je peux réduire le nombre de lignes...
P. S. Précision : j'ai déjà essayé de grouper quelques lignes sur une seule par :
=SI(B1=1;D1;SI(B1=2;D2;SI(B1=3;D3;A2))) mais le nombre maximum d'arguments dans une unique cellule n'est pas suffisant à résorber le trop plein...

2 réponses

Messages postés
702
Date d'inscription
mercredi 30 août 2006
Statut
Membre
Dernière intervention
26 février 2019
64
La formule que tu cherches est la formule recherche valeur "RECHERCHEV"

Tu trouvera une explication comment l'utiliser ici: <url>http://www.excel-pratique.com/fr/fonctions/recherchev.php</url>
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merciiiiiiiiiiiiiiiii c'est çàààààààààà !
Messages postés
23605
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
31 octobre 2020
6 434
Bonjour,

cellule B1 : recherche d'un article par son prix
Parce qu'un prix = un article unique ????
Tu es sûr de ta méthodologie ???

Tu peux déposer un fichier exemple (qcq lignes) avec des explications sur cjoint.com et coller ici le lien fourni.

eric
Heu.... je précisais aussi que c'était à titre d'exemple que je parlais de prix et d'articles, mon classeur n'a rien à voir ni avec l'un, ni avec l'autre. Si tu préfères :
Colonne C : liste de bidules ; colonne D : liste de trucs ; cellule B1 : recherche de truc par son bidule ;)

(mais la réponse de Fyah_Fy est exactement celle qu'il me fallait, merci quand même)