Excel et fonction ALEA()

Résolu/Fermé
carthagod
Messages postés
33
Date d'inscription
mercredi 21 octobre 2009
Statut
Membre
Dernière intervention
4 mars 2013
- 3 déc. 2011 à 10:11
carthagod
Messages postés
33
Date d'inscription
mercredi 21 octobre 2009
Statut
Membre
Dernière intervention
4 mars 2013
- 3 déc. 2011 à 12:52
Bonjour à tous,

Il se passe quelque chose que je ne comprends pas dans Excel. Je veux simuler une somme de 20 variables aléatoires suivant une loi uniforme en 0 et 1 (le but étant de montrer que ça tend vers une loi normale). J'utilise donc la fonction ALEA(). Seulement voilà :
- Si dans une cellule j'entre "=ALEA()+ALEA()+ALEA()+ALEA() etc..." tout se passe bien, ça fonctionne
- Si j'entre dans 20 cellules différentes "=ALEA()" et qu'ensuite je fais la somme de ces cellules, j'obtiens toujours le même nombre ?!? Très bizarre non ?

Est ce que qqn sait pourquoi ?
cf fichier ici pour exemple : http://dl.dropbox.com/u/30908543/Classeur1.xls

Merci de m'éclairer !

Thomas

2 réponses

eriiic
Messages postés
24381
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
16 mai 2022
7 072
Modifié par eriiic le 3/12/2011 à 11:02
Bonjour,

déjà ta somme doit plutôt être =SOMME(A1:T1)
Ensuite tu as désactivé le calcul automatique, remet-le dans 'outils / options / calcul'
Maintenant c'est vrai qu'avec F9 il devait recalculer et qu'il ne le faisait pas à cause de l'auto référence...

eric
1
carthagod
Messages postés
33
Date d'inscription
mercredi 21 octobre 2009
Statut
Membre
Dernière intervention
4 mars 2013
1
3 déc. 2011 à 12:52
ah oui, je suis trop con, c'est l'auto référence... Pour le calcul automatique j'avais vu, mais ça ne fonctionnait pas avec F9, forcément à cause de la somme...

Merci pour le coup de main :)
0