Excel, formule 2 plages plusieurs critères [Résolu/Fermé]

Signaler
-
 Lise -
Bonjour,

Je rechercher une fonction pour Excel 2003. Voilà mon problème:
J'ai dans la colonne A des dates d'immatriculation (sous forme 01.10.2005) et dans la colonne B des modèles (106,107,206, 3008, 1007...).

Je cherche à savoir le nombre de 106 ou 107 qui ont
-moins de 2 ans (donc dont la date d'immatriculation est supérieure à 01.10.2009),
-entre 2 et 4 ans (donc comprises entre 01.10.2007 et 01.10.2009)
-entre 4 et 8 ans
-plus de 8 ans.

Je cherche une formule qui me permettrait de sélectionner un critère pour une plage (date) et 2 critères (ou plus) pour une autre plage (modèle).

Avec nb.si.ens dans word 2007 ca ne devrait pas pose de problème, mais malhaureusement la fonction n'existe pas pour word 2003.. J'ai essayé sommeprod, sans succès, même en changeant la syntaxe des dates (en les mettant sous forme "chiffre" 39000)

Si quelqu'un a une idée, ca m'aiderait beaucoup :)
Meci d'avance,
Lise

9 réponses

Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bonjour
le code SOMMEPROD devrait marcher, que vous renvoie t il ?

:
=SOMMEPROD((champ1=critére 1)*(Champ2=critère2)*(champ3=critére3))

bien sur le signe égal peut être remplacé par: > < => =<
ainsi pour une fourchette entre deux dates:
=SOMMEPROD((champ date>=date mini)*(champ date<=Date maxi))
pour avoir le nombre de référence entre ces deux dates incluses.
notes:
_il vaut mieux placer les dates limites dans des cellules et remplacer Date maxi et Date mini par l'adresse de ces cellules;
_SOMMEPROD n'accepte pas d'adresse de champ sans n° de ligne du type A:A
_vous pouvez placer autant de conditions que vous voulez en multipliant les items (....=....)
_ si votre critère et numérique, il ne faut pas de valeur texte dans le champ.
_ si vous placez en dernier un item sans critères ex:(X1:X100)); SOMMEPROD vous fera le total de cette colonne pour les lignes correspondantes aux autres critères.
revenez si besoin de plus d'info.




crdlmnt

Messages postés
17302
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 avril 2021
4 547
Salut,

Je pense que l'erreur vient du formatage des dates non reconnu par Excel
"entre 01.10.2007 et 01.10.2009"
soit on utilise un format en fonction des options régionales déclarés dans le système ex. 01/10/2007 ou on crée un format personnalisé si cela n'est pas le cas
jj.mm.aaaa ce qui affichera 01.10.2011 mais la saisie devra 1/10/11 ou 1/10/2011 ou encore 01/10/2011 etc ...
Merci!
Je pense que sommeprod ne marche pas car dans ma colonne "modèle", j'ai des cellules contenant "peugeot 106" ou bien "206 Petit filou". Du coup il affiche #NOMBRE!

(pour les dates, j'avais réglé le problème en les mettant sous forme de chiffres)
Messages postés
17302
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
9 avril 2021
4 547
Re,

Peux tu mettre à notre disposition un exemple de fichier sans notes confidentielles à joindre avec un de ces liens

https://www.cjoint.com/ ou http://www.cijoint.fr/
Voila un petit exemple:

http://cjoint.com/?0KyplIMXyei
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Bien vu l'exemple, mais vous cherchez quoi comme résultat, quels sont les critères de recherche hormis les dates?

L'info est importante, car SOMMEPROD peut chercher en fonction de textes bien positionné dans les libellés
Par exemple, pour avoir le nombre de cellules dont le texte commence par 206 dans votre liste en B:
=SOMMEPROD((GAUCHE((B1:B100;3)="206")*1)
et bien sur vous pouvez y associer des items date limites comme nous l'avons déjà évoqué.

Par contre, tous vos libellé ne fonctionneront pas sur le même type, d'où l'importance des précisions.
A vous lire ?
crdlmnt
Bizarre, ça ne marche pas ... :/

Comme résultat, je cherche le nombre de 106 et 107 (les deux modèles à la fois) qui ont moins de 2ans. (puis entre 2 et 4 ans, etc)
Messages postés
25953
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 avril 2021
5 866
Re
ne sachant pas à quelle date vous évaluez l'age du véhicule, pour avoir un résultat avec votre modéle:

=SOMMEPROD((A1:A1000>AUJOURDHUI()-730)*(GAUCHE(B1:B1000;3)="207"))
(renvoi 1 dans votre modèle)
vous pouvez bien sur remplacer AUJOURDHUI()-730 par l'adresse d'une cellule ou vous mettrez la date de "naissance " du véhicule cherché.
Crdlmnt

Ps si vous entrez 206 dans une cellule pour faire référence, placer le en commençant par une apostrophe afin que ce soit un texte.
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
YES ça marche!! Merci beaucoup :)