Publipostage champs vides....si paragraphe [Fermé]

Signaler
-
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
-
Bonjour,

Je ne trouve pas de réponse à ma question, pourtant il me semble que cela soit courant.
Je ne dois peut être pas utiliser les bon termes de recherche et je suis désolé si la question est courante.

J'ai un fichier d'adresse avec nom, prénom, c/o, rue, np, ville

La mise ne page désirée est
nom, prénom
c/o
rue
np ville

Mon soucis est que dans les adresses ou c/o est vide Word me laisse une ligne vide.

Est-il possible que dans Word les lignes vides (c/o) n'apparaissent pas ?
Soit :
nom, prénom
rue
np ville

Et non une ligne vide pour la ligne c/o

J'ai Word 2007 ;-)

En fait je viens de remarquer que si dans ma mise en page, il y a un espace entre les paragraphes, j'ai cette ligne qui apparait, si non, les lignes vides n'apparaissent pas.
Qui à une idée ?


5 réponses

Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 771
Bonjour,

La question est souvent revenue effectivement :)
Tu peux récupérer l'option "ignorer les lignes vides" comme dans les anciennes versions, en personnalisant la barre d'outils rapide :
Bouton Office / options word / Personnaliser / catégorie : toutes les commandes / Fusion et publibostage / ajouter / OK

Et là tu peux cocher "ignorer les lignes vides". Qui devrait d'ailleurs être déjà activé, mais à vérifier :)
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Merci argixu

Mais en fait, le problème est que si dans la mise en forme du texte, dans les options de paragraphe j'ai un espace (Accueil -> paragraphe -> espacement -> après) j'ai ma ligne qui apparait.

Si ce réglage est à zéro, les lignes vides disparaissent.

Cela m'intrigue :-)
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 771
Va au bout de la fusion : terminer et fusionner vers un nouveau doc
Espace ou pas, tu n'as pas de lignes vides
Je suis allé au bout de la fusion et si dans mes paramètres j'ai un espace de régler pour les espaces après les paragraphes, j'ai une ligne vide.

Si je modifie et met 0 à cette option, je n'ai pas de ligne vide.

Il va de soit qu'entre les ligne de la fusion, j'ai fait "enter" pour revenir à la ligne et créer un nouveau paragraphe.
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 771
Re,

Si tu as des lignes ignorées selon l'espacement du paragraphe, là, impossible de reproduire ton problème ! Elles sont ignorées, point. Il n'y a que si on veut les maintenir qu'il faut forcer.
Avec un espacement paragraphe, effectivement, l'aperçu des résultats est trompeur, il faut terminer la fusion.

Est-ce que tu pourrais nous joindre ton fichier sans données confidentielles. Pour voir si on a le même problème.
Avec https://www.cjoint.com/ et colle ensuite le lien fourni ici sur ta réponse.

Argitxu
Génial le lien, super pratique

Voici la base de donnée (Excel) : http://cjoint.com/?0KwiuGVyzLu

Et le fichier, qui est fait pour reprendre le problème, l'original est confidentiel : http://cjoint.com/?0KwiGkdGuhX

Ainsi qu'un PDF, réalisé avec PDF creator en imprimant le publipostage : http://cjoint.com/?0KwiHnYkc7T

Et le même publipostage sans espace en fin de paragraphe :
http://cjoint.com/?0KwiKsiEMct

Ainsi qu'une image du paramètre d'espace de paragraphe qui me chagrine : http://cjoint.com/?0KwiPDMXfAt

En vous remerciant du temps que vous passez à m'aider.
Messages postés
4797
Date d'inscription
dimanche 22 juillet 2007
Statut
Contributeur
Dernière intervention
18 décembre 2018
3 771
Bonsoir,

Sans surprise, mon test avec tes fichiers ignore bien la ligne.

Dans ton exemple, il n'y a pas de saut de ligne, la dernière ligne est décalée. On voit bien sur les deux corps d'adresse un léger décalage sur la dernière ligne, mais ce n'est pas un paragraphe de 1,15 et un espacement après de 10.
Si tu affiches les marques de mise en forme (Ctrl+Maj+8), tu devrais mieux le voir.

Par contre, ton problème doit venir des langues asiatiques activées sur ton poste que je vois avec le menu Paragraphe que tu as déposé.
Teste en les désactivant ( Démarrer, Programmes, Microsoft Office, Outils, Paramètres langue Office...)


Argitxu