EXCEL - date + 1 an = alerte

[Résolu/Fermé]
Signaler
-
 Finch -
Bonjour,

Bon je ne savais pas comment formuler ma question, d'où mon titre un peu bizare ^^

J'ai un tableau excel tout bète, dans lequel la dernière colonne est renseigné par une date. J'aimerai parvenir à la chose suivant : la cellule E1 me renseigne du nombre de ligne à mettre à jour, c'est à dire le nombre ligne où cette fameuse date est dépassée d'une année.

Par exemple :
Aujourd'hui nous sommes le 20/11/2011
Mon tableau comporte :
1 ligne avec en date 01/12/2010
1 ligne avec en date 01/11/2010
Alors la case E1 me dit : "vous avez 1 ligne à mettre à jour"

(si tout est à jour alors "aucune ligne n'est à mettre à jour").

J'espère être le plus clair possible, quelqu'un peut il m'aider ?

5 réponses

Messages postés
17572
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 octobre 2021
4 767
Salut,

Pas très clair comme explication, serait il possible d'avoir ton fichier sans notes confidentielles et quelques notes explicative que l'on voit sa structure. a joindre avec un de ces liens

https://www.cjoint.com/ ou http://www.cijoint.fr/
ce pc n'a que Open Office, mais le principe est simple pourtant (en tout cas dans ma tête)

au bout de chaque ligne il y a une date, si la date + 1 an dépasse la date d'aujourd'hui, alors tout va bien,
exemple : 01/01/2011, +1 an ça nous fait 01/01/2012, on dépasse la date d'aujourd'hui le 20/11/2011, donc la ligne n'est pas à mettre à jour.

si la date + 1 an est inférieure à la date d'aujourd'hui, alors E1 me dit "X lignes à mettre à jour"
exemple : 01/01/2010, +1 an ça nous fait 01/01/2011, on est inférieur à la date d'aujourd'hui le 20/11/2011, donc la ligne est à mettre à jour.

C'est plus clair la ?
Messages postés
9
Date d'inscription
dimanche 20 novembre 2011
Statut
Membre
Dernière intervention
23 novembre 2011
1
ok pour ton raisonnement mais remplacer 1 an par 365 (le tableur comprends en jour) et mettre la formule AUJOURDHUI afin d'insérer la date automatiquement .à chaque ouverture du document.
@+
;)
Messages postés
9
Date d'inscription
dimanche 20 novembre 2011
Statut
Membre
Dernière intervention
23 novembre 2011
1
voici la procédure


A B C
1 aujourd'hui =AUJOURDHUI()
2 première date 01/12/2010 =SI($B$1-B2>365;"alerte";"")
3 deuxième date 01/11/2010

- En B1 cette formule permets d'afficher la date du jour automatiquement.
- En C2 si la date d'aujourd'hui que l'on a placée en b$1$ déduite de la première date est supérieure à 365, il y aura le message "alerte" si non "" c'est à dire rien.
- copier la formule

NB : Modifier le 365 dans la formule pour les années bissextiles

Bon courage
Pascal
Messages postés
16523
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 septembre 2021
3 228
bonjour

regarde si cette maquette te convient, quelque soit l'année bissextile ou non

j'ai préféré 2 cellules intermédiaires mais tu peux tout regrouper dans une seule formule

https://www.cjoint.com/?3KusKaZTL0I
Merci, avec tout ça je pense pouvoir ma tite manip, sujet clos ^^