Installer le serveur graphique sous Debian

Résolu/Fermé
Matgic - 1 sept. 2006 à 18:11
mamiemando Messages postés 33192 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 17 juillet 2024 - 16 janv. 2009 à 12:16
Bonjour ,

Je débute sur Linux et j'ai choisis d'installer la distrib Debian en suivant une formation : http://people.via.ecp.fr/~alexis/formation-linux/xfree.html

Donc j'ai telechargé une image que j'ai gravé sur un CD et fait l'install avec ce seul CD. L'install s'est bien passé et maintenant j'aimerais avoir l'inerface graphique.

Donc je fais :

apt-get install x-window-system-core

et on me dit :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Aucune version est disponible mais il existe dans la base de données.
E: Aucun paquet ne correspond au paquet x-window-system-core

j'ai également fait:

apt-cache search x-window pour faire une recherche du paquet.

On me dit :

xfree86-common - X Window System (XFree86) infrastructure

Donc je sais pas trop quoi faire , le mode console c sympa mais j'ai peur de m'y perdre avec toutes ces commandes.

Merci d'avance pour vos réponses.

4 réponses

mamiemando Messages postés 33192 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 17 juillet 2024 7 762
1 sept. 2006 à 19:03
N'installes pas xfree86 installe directement xorg. Exemple chez moi, j'ai mis :
ii  xserver-xorg-core                1.0.2-9                     X.Org X server -- core server
ii  xserver-xorg-input-evdev         1.0.0.5-2                   X.Org X server -- evdev input driver
ii  xserver-xorg-input-kbd           1.0.1.3-2                   X.Org X server -- keyboard input driver
ii  xserver-xorg-input-mouse         1.0.4-3                     X.Org X server -- mouse input driver
rc  xserver-xorg-input-wacom         0.7.4.1-3                   X.Org X server -- wacom input driver
ii  xserver-xorg-video-dummy         0.1.0.5-2                   X.Org X server -- dummy display driver
ii  xserver-xorg-video-fbdev         0.1.0.5-2                   X.Org X server -- fbdev display driver
ii  xserver-xorg-video-nv            1.0.1.5-2                   X.Org X server -- NV display driver
ii  xserver-xorg-video-v4l           0.0.1.5-1                   X.Org X server -- Video 4 Linux display driv
ii  xserver-xorg-video-vesa          1.0.1.3-2                   X.Org X server -- VESA display driver
ii  xserver-xorg-video-vga           4.0.0.5-2                   X.Org X server -- VGA display driver
ii  xserver-xorg-video-via           0.1.33.2-3                  X.Org X server -- VIA display driver

... pour un chipset via (ma carte mère) et le driver libre nvidia. A toi d'adapter, le plus simple étant de sélectionner les paquets à installer avec aptitude (+ pour marquer un paquet à installer, puis g,g quand tu as tout sélectionné). Ensuite installes le window manager de ton choix (gnome, kde, icewm...).
Ensuite si le script de configuration ne se charge pas de lui-même, tape en root :
dpkg-reconfigure xserver-xorg

Ce sera notamment l'occasion de choisir de lancer kdm/gdm au démarrage pour te logger en graphique. Ensuite une fois que tout est près, si par exemple tu utilises kdm :
/etc/init.d/kdm restart

Si tout est correctement configuré tu devrais voir le mode graphique s'afficher (ctrl alt f7). Sinon il y a une erreur dans ton fichier de configuration /etc/X11/xorg.conf. Pour voir où est le problème il suffit de regarder dans /var/log/Xorg.0.log ce qui s'est passé, puis corriger le problème soit en modifiant directement /etc/X11/xorg.conf, soit en utilisant la commande :
dpkg-reconfigure xserver-xorg

Bonne chance
Salut,

Merci pour ta réponse je vais essayer.
0
bonjour

tout d'abord il faut que tu mets ajours ton sources.list

nano /etc/apt/sources.list


puis yu mets le caractere # avnat ou il ya deb cdrom ......
et tu mets le bon meroir de serveur debian
come deb http://ftp.fr.ubunto.fr ....



et puis tu fait un apt-get install update
et puis tu tape la commande que tu veux faire installer le system graphique



salutations
mamiemando Messages postés 33192 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 17 juillet 2024 7 762
21 sept. 2008 à 12:22
Depuis deux ans je pense qu'il a dû résoudre son problème ;-)
Merci mamiemando!
j'avais un gros problème et grâce à toi j'ai pu le résoudre, alors que cela faisait plusieurs heures que je cherchais la solution sur le net...
MERCI
MERCI
MERCI
MERCI
0
mamiemando Messages postés 33192 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 17 juillet 2024 7 762
16 janv. 2009 à 12:16
De rien ^^ Heureuse de voir que tu es si content de l'avoir résolu ^^