Formule excel avec lien autre feuille [Résolu/Fermé]

Signaler
Messages postés
88
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
7 janvier 2015
-
 gnioler -
Bonjour,





bonjour
j'ai une formule excel dans une cellule du classeur 1 de la feuille 1 qui fait un comparatif de recherche de mots avec une autre cellule dans un autre classeur
mais si cet autre classeur est fermé il me met #valeur, par contre si l'autre feuille est ouverte ca marche, je souhaiterai savoir ce qui cloche dans ma formule

=SI(NB.SI([TARIFxls]tariftp!A2:[TARIF.xls]tariftp!A2;"*"&'DEVIS TP.xlsm'!recherchedesi:recherchedesi&"*")=1;MAX($A$1:A1)+1;0)

recherchedesi est une cellule dans laquelle je tape ma recherche
TARIF est le deuxieme fichier fermé
tariftp est la zone renomé de mon tarif du deuxieme fichier
DEVIS TP est le 1er fichier dans lequel il a cette formule et aussla zone de recherche

merci pour votre aide

5 réponses

Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 683
Bonjour,

Avec un exemple de tes deux fichiers zippés déposés sur https://www.cjoint.com/ ou sur http://cijoint.fr/ cela aurait été plus simple.

Réponse :
1. Tu as oublié de donner le nom de la feuille de TARIF.xls dans laquelle se situe la plage nommée "tariftp", pour l'exemple je considère que c'est Tarif 2011
2. Ta formule n'est pas bonne mais c'est pas grave car avec cette formule il faudrait ouvrir TARIF.xls
3. Pour éviter d'ouvrir le second fichier, il faut avoir les données dans le classeur DEVIS TP (sur une feuille Tarif qui reproduit les données de TARIF.xls). La plage nommée "tariftp" dans TARIF.xls n'est plus nécessaire.
4. Tu peux établir une connexion entre les deux classeurs afin de pouvoir actualiser facilement les données :
- à partir de A1 de la feuille Tarif de DEVIS TP / Onglet Données /
- groupe Données externes - A partir d'autres sources /
- Provenance : Assistant de connexion de données /
- DSN ODBC / Fichiers Excel /
- sélectionner le fichier TARIF.xls
- sélectionner la feuille 'Tarif 2011$'
5. Ultérieurement, pour actualiser le tarif il suffira de faire: clic droit / Actualiser
6. Excel donne automatiquement un nom à la plage de données importée sur la feuille Tarif de DEVIS TP (dans l'exemple : Tableau_Tarif__Tarif_2011)
7. la formule en A2 de ta feuille de calcul pourrait être :
=SI(NB.SI(DECALER(Tableau_Tarif__Tarif_2011;;;;1);"*"&recherchedesi&"*")=1;MAX($A$1:A1)+1;0)
à tirer vers le bas. La plage nommée "recherche si" occuperait le même nombre de lignes

Mais il est probable que cela ne corresponde pas à ton besoin puisque tu ne l'a pas exprimé dans l'exposé de ton problème !

--
Cordialement
Patrice
Messages postés
88
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
7 janvier 2015
2
bonjour et merci pour votre reponse

j'ai un souci car je ne peut pas mettre les données dans le meme classeur

le classeur TARIF doit etre independant du classeur DEVIS TP

pour repondre a tes remarque

1 le nom de la feuille de TARIF.XLS c'est tariftp je n'est pas donné le nom de la plage est ce necessaire de le rajouter car il regarde la cellule A2

2 tu dit que ma formule n'est pas bonne ok mais justement je voudait ce qu'il faut modifier dans ma formule pour ne pas ouvrir TARIF

3 je peut pas car il me faut les données tarif a part

4,5,6,7 je vais essayer pour voir si c'est ce que je cherche

merci d'avance
Messages postés
88
Date d'inscription
mercredi 5 octobre 2011
Statut
Membre
Dernière intervention
7 janvier 2015
2
je viens d'essayer cette derniere methode ca marche tres bien
je vais utiliser cette methode pour l'instant
mais je vais en chercher une autre car je ne peut pas laisser la liste tarif complete avec le fichier devis

merci beaucoup pour votre aide
si vous avez une autre idée je suis preneur
Messages postés
8539
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 juillet 2021
1 683
tu peux peut-être faire l'inverse:
- Ajouter une feuille devis au fichier Tarif
- Copier cette feuille dans DEVIS TP par des des simples formules =cellule du fichier TARIF feuille Devis
merci pour votre aide je vais essayer