EXCEL les fonctions avec des heures

Résolu/Fermé
Signaler
Messages postés
166
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
23 octobre 2016
-
Messages postés
166
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
23 octobre 2016
-
Bonjour,

J'ai besoin de mettre une formule dans deux cases différentes répondant à des conditions avec des heures.

Exemple :

Si dans la cellule A1 le nombre d'heures est supérieur ou égal à 14 heures, calculer 40% de ce nombre, sinon rien

Si dans la cellule A1 le nombre d'heures est inférieur ou égal à 14 heures, calculer 15% de ce nombre, sinon rien.

Dans A1, j'ai mis le format personnalisé hh:mm
mais, mes formules, les voici :

=si(A1>=14;A1*40%;"")

=si(A1<=14;A1*14%;"")

Ce là ne fonctionne pas correctement.

Ai je utiisé les bonnes fonctions ? Ai-je mis les bons formats ?

C'est une suivi des heures supplémentaires et de leur majoration.

Si quelqu'un peut m'aider ça serait sympa.

Merci et bonne journée !


4 réponses

Messages postés
24221
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 novembre 2021
6 973
Bonjour,

Il y a juste un élément que tu n'as pas : excel stocke en interne les heures comme une fraction de jour.
Par exemple 6:00 = 0.25 , 24:00 = 1
Date-heure sont dans un seul nombre, les jours pour la partie entière, la partie décimale pour les heures, minutes, secondes.

Si tu veux tester les heures il faut donc x24 :
=si(A1*24>=14;A1*40%;"")

eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
10183
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
26 novembre 2021
2 251
bonjour

pour la 1°, la cellule B2 étant au format hh:mm
B2=SI(A2*24>=14;A2*40%;"")

bonne suite
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
3 249
bonjour
=SI(A1>=14/24;A1*40%;"") à mettre au format hh:mm

tu as 2 résultats si A1=14:00....?
Michel
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 364
Bonjour,

EXcel ne peut pas faire le calcul à partir de ton format hh:mm. il faut que tu "décimalises" tes heures situées dans la colonne A.
Tu peux rajouter une colonne (qui pourra être masquée) avec la formule suivante :

=HEURE(A2)+MINUTE(A2)/60

et modifier tes formules avec cette nouvelle adresse.

A+

pépé
Messages postés
24221
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 novembre 2021
6 973
Bonjour,

EXcel ne peut pas faire le calcul à partir de ton format hh:mm
Bien sûr que si il peut, regarde les 2 autres réponses
eric
Messages postés
166
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
23 octobre 2016

Oui effectivement je viens d'essayer avec =si(A1*24>=14;A1*40%;"")

et ça fonctionne bien.
J'ai juste un bémol. dans mon total heures, celle-ci dépassent 24:00 du coup cela ne me met en total que les haures depassant exemple : 25:30 le resultat est 1:30
Ma formule c'est somme() des cellules qui elles memes sont des résulats de formules

Leur formats est bien hh:mm mais je ne sais pas comment faire.
Messages postés
16537
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 novembre 2021
3 249
tu mets au format-nombre personnalisé [hh]:mm
Messages postés
166
Date d'inscription
samedi 31 mai 2008
Statut
Membre
Dernière intervention
23 octobre 2016

Merci ! c'est bon, effectivement, c'est ce qui manquait.

MERCI A VOUS TOUS !