Comment modifier localhost par mon ip serveur

Résolu/Fermé
ludo04 - 16 sept. 2011 à 09:18
 amal - 17 déc. 2013 à 11:28
Bonjour,

j'ai installé Easyphp sur mon serveur 2008, mais j'aimerais changer l'adresse "localhost" (ou 127.0.0.1) par mon ip du serveur 172.16.x.x afin de déployer mon application sur les postes clients de mon réseau local, mais je ne sais pas comment faire car j'ai modifié le fichier host mais rien ne change.

Merci d'avance pour votre aide



6 réponses

merci encore pour ton aide j'ai trouvé la réponse a mon problème!!! il fallai simplement modifier le fichier de conf du serveur apacha en rajoutant l'adresse ip souhaité!!!!
1
Ammoula89 Messages postés 45 Date d'inscription mardi 31 janvier 2012 Statut Membre Dernière intervention 10 mars 2014
7 févr. 2012 à 09:47
s'il vous plait pouvez vous me dire comment rajouter l'adresse ip souhaité et ou précisément !!!
0
Il faut tout d'abord aller sur l'icone d'easyphp configuration/apache
chercher la ligne "listen " généralement suivie de 127.0.0.1:80 et remplacer cette ip par celle du post local (désormais l'acces ce fera par le navigateur via cette adresse ip) avec tjs derriere :80.
Puis ensuite, Trouver la ligne "Alias /mysql/ phpmyadmin" en dessous c'est écrit "allow from 127.0.0.1" remplacer par "allow from 192.168.0.x" puis enregistrer. "

Sauf que si tu veux pouvoir continuer à bosser en ouvrant le Web Local (F7), tu ne pourra pas.
La solution est encore plus simple, au lieu de "Remplacer", tu "Ajoutes" en recopiant la ligne juste en dessous, mais en mettant TON adresse. comme ceci :

Listen 127.0.0.1:80
Listen 192.168.x.x:80

puis

<Directory "${path}/phpmyadmin">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
allow from 192.168.x.x
deny from all
</Directory>

<Directory "${path}/sqlitemanager">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
allow from 192.168.x.x
deny from all
</Directory>

<Directory "${path}/home">
Options FollowSymLinks Indexes
AllowOverride None
Order deny,allow
allow from 127.0.0.1
allow from 192.168.x.x
deny from all

Et tout est réglé !! pas besoin de touche au .htaccess ni rien d'autre...
-2
Déjà merci d'avoir répondu si vite.

ba lorsque je suis sur un poste client de mon reseau je tape l'adresse ip de mon serveur 2008 suivie du nom de l'application que je veux faire fonctionné mais il ne me trouve pas la page. ( en local sur mon serveur tous fonctionne).
comment puis-je mettre easyphp en "mode en ligne"?
j'ai aussi vu sur google que je devais modifier la configuration de apache mais la je suis un peux perdu dans le changement de mon ip

Merci
0
thevinou Messages postés 1007 Date d'inscription lundi 28 février 2011 Statut Membre Dernière intervention 10 mars 2015 189
16 sept. 2011 à 10:00
Ton serveur authorise t'il les connexions sur le port 80 ?
0
oui il autorise bien les connexions sur le ports 80
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
thevinou Messages postés 1007 Date d'inscription lundi 28 février 2011 Statut Membre Dernière intervention 10 mars 2015 189
16 sept. 2011 à 10:25
Essaie de changer ton port 80 en 8080 sur easyphp, et assure toi que le port 8080 est ouvert
0
thevinou Messages postés 1007 Date d'inscription lundi 28 février 2011 Statut Membre Dernière intervention 10 mars 2015 189
16 sept. 2011 à 09:27
Le fichier HOST sert à éviter de rechercher des DNS externes et s'applique donc à 1 seule machine.

Vous avez un site sur une machine et voulez le rendre accessible des autres ? et ça ne marche pas par l'ip reseau ?

Essayez de passer easyphp en mode "en ligne" et tout fonctionnera à partir des autres PC
-1