Comparer deux colonnes sous excel 2007 [Résolu/Fermé]

Signaler
Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
-
Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
-
Bonjour,

Je suis novice sous Excel et je recherche une formule me permettant de comparer et d'identifier si une date a été modifiée. Je m'explique, cela sera plus simple :

Dans mon classeur, j'ai deux feuille (Feuille1 et Feuille2)

Dans la Feuille1, j'ai une donnée en colonne A ( N° de dossier; 556625) et une donnée en colonne L (Date;18/08/2011)

Dans la Feuille2, j'ai une donnée en colonne B (N° de dossier 556625 qui est le même) et une donnée en colonne M ( Date;25/08/2011 qui n'est plus la même)

Le formule que je recherche me permettrai d'identifier en fonction du N° de dossier, la date qui a été changé.

Je remercie d'avance de l'aide que vous pourrez m'apporter sur cette formule.

Dans l'attente de vos retours.

Bien cordialement,

Epsson.


8 réponses

Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
19
Bonjour,

Super !! Ca fonctionne très bien !! :-)

Merci Mike !!

Je remercie au passage Eric et Patrice...

A bientôt messieurs et encore merci pour votre réactivité...
19
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
8354
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
22 janvier 2021
1 572
Sur la ligne 2 d'une colonne libre :
='Feuille1'!L2='Feuille2'!M2
à tirer vers le bas
Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
19
Dsl cela ne fonctionne pas :-(
Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
19
Bonjour Patrice,

Merci pour ta réactivité ! :-)

J'ai essayé mais cela ne fonctionne pas :-(


J'ai une feuille1 ou le numéro de dossier correspond à une date d'intervention.

A L
556625 18/08/2011

J'ai une feuille 2 ou ce même numéro de dossier à une date d'intervention qui a été modifier

A M
556625 25/08/2011

Je dois identifier tous les numéros de dossier pour lequel la date d'intervention à été modifiée...

J'espère avoir été clair dans mon exposé, je suis désolé je ne suis pas expert en la matière.

Merci Patrice pour ton retour
Messages postés
8354
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
22 janvier 2021
1 572
C'est probablement que les feuilles sont différentes de la description que tu en fait.
Peut-être que la liste des dossiers n'est pas la même !
bonsoir,

le N° de dossier est-il sur le même numéro de ligne en feuille 1 et en feuille 2 ?
l'identification des dossiers modifiés se fait en feuille 1 ou en feuille 2 ?

A+
Messages postés
23813
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
6 590
Bonjour,

avec en Feuil2!A2 le n° et en B2 la date :
=SI(B2=INDEX(Feuil1!B:B;EQUIV(A2;Feuil1!A:A;0));"ok";"nok")

eric
Messages postés
7
Date d'inscription
jeudi 9 février 2006
Statut
Membre
Dernière intervention
25 août 2011
19
Bonjour,

La formule ne fonctionne pas, je vous joint un exemple.

J'aimerai comparer les colonnes A et B des Feuille1 et Feuille2. Si la date ne correspond pas au N° de dossier, alors j'aimerai avoir une alerte.

Voici le fichier exemple :

http://www.cijoint.fr/cjlink.php?file=cj201108/cijyRw7md6.xls

Merci pour votre aide
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 443
Salut,

Colle cette formule en C2 ou D2 par exemple sur la feuille 1 et incrémente vers le bas

=SI(RECHERCHEV(A2;Feuil2!A1:B9;2;0)=B2;"inchangée";"changée")

ou cette formule feuille 2 sur la ligne 2

=SI(RECHERCHEV(A2;Feuil1!A1:B9;2;0)=B2;"inchangée";"changée")

si c'est que tu cherches, il est possible d'améliorer la formule