[Formule Excel] =INDIRECT

Résolu/Fermé
Darkam1 Messages postés 170 Date d'inscription mardi 9 août 2011 Statut Membre Dernière intervention 22 février 2016 - 23 août 2011 à 10:39
Darkam1 Messages postés 170 Date d'inscription mardi 9 août 2011 Statut Membre Dernière intervention 22 février 2016 - 24 août 2011 à 11:09
Bonjour,

Voici ma formule qui me pose problème.

La fonction Indirect va rechercher si la cellule V2 comprend une feuille avec le même nom inscrit en V2. Si oui, alors elle va chercher dans cette feuille en C14 "X". Si il y a "X" d'écrit, alors inscrire "Test" dans la cellule ou se situe ma formule.

=INDIRECT(V2&"!C14="X";"Test";""")

Malheureusement, cette formule ne fonctionne pas !

Un coup de pouce ?

Amicalement



2 réponses

Raymond PENTIER Messages postés 56847 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 décembre 2022 17 182
24 août 2011 à 03:45
Bonjour.

Effectivement elle ne risque pas de marcher, car tu as oublié :

1) le principal : la fonction SI au début
=SI(INDIRECT(....
2) de fermer les guillemets après "!C14
(V2&"!C14" ...
3) de fermer la parenthèse de INDIRECT
INDIRECT(V2&"!C14")="X" ...

Et, tu verras, =SI(INDIRECT(V2&"!C14")="X";"Test";"") marche très bien :-))

Cordialement.
3
Darkam1 Messages postés 170 Date d'inscription mardi 9 août 2011 Statut Membre Dernière intervention 22 février 2016 18
24 août 2011 à 11:09
Un grand merci ! La formule fonctionne parfaitement. A bientôt sur CCM.

Amicalement
0