Serveur DHCP Linux Debian+Client XP [Résolu/Fermé]

Signaler
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
-
 yousrag -
Bonjour,
j'ai actuellement une machine virtuelle Debian qui fait office de serveur DHCP, DNS et serveur de messagerie. En parallèle, j'ai un client Windows XP. Je parviens a pinger dans les 2 sens les adresses IP (XP vers Debian et vice-versa), et je parviens a pinger mon domaine a partir de mon client XP.

Je souhaiterais que ma machine XP ait une adresse IP attribuée dynamiquement par mon serveur DHCP Unix. Comment faire? Que faut-il paramétrer sur ma machine virtuelle XP?

Merci d'avance.

15 réponses

Bonjour voici un lien qui peut peut être t'aider côté serveur si c'est ce que tu cherches:

http://www.siteduzero.com/tutoriel-3-277701-mise-en-place-d-un-serveur-dhcp-sous-linux.html

Bonne journée ;)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Je souhaiterais en fait savoir comment attribuer une adresse a ma VM Windows XP via mon serveur DHCP Debian sachant que les 2 VM communiquent bien entre elles.

C'est surtout les paramètres de la la machine cliente qui m'intéressent.

Merci d'avance.
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Personne ne peut m'aider?
Messages postés
35
Date d'inscription
dimanche 31 octobre 2004
Statut
Membre
Dernière intervention
17 août 2011
1
Bonjour,
il y a rien à paramétrer, si ton serveur dhcp est bien configuré il devrait distribuer les @ip sans problème.
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Je veux bien croire mais mon serveur DHCP fonctionne avec une VM Debian en client mais pas avec une machine XP.
Une adresse est allouée mais pas dans la plage ce qui signifie d'après moi que ce n'est pas mon serveur DHCP qui distribue l'adresse mais autre chose.
Si vous voulez que je vous montre le contenu de mes fichiers de conf n'hésitez pas a demander.

As-tu bien pensé à ajouter l'adresse DNS de ton serveur dans les paramètres TCP/IPv4 de ta machine XP?
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Oui j'ai bien rajouté l'adresse IP de mon serveur DNS dans les paramètres avancés et l'onglet DNS de ma machine XP. Une adresse est attribuée mais pas dans la plage que j'ai définie.
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Je veux bien vous donner les contenu des fichiers de conf qui pourraient poser problème si ça vous permet d'y voir plus clair.
Messages postés
291
Date d'inscription
lundi 5 mai 2008
Statut
Membre
Dernière intervention
22 juin 2014
35
Regarde dans les paramètres de ta carte réseau que tu est bien en configuration automatique (DHCP).

Après tu peux essayer dans un terminal, (windows + R ---> cmd ), les commandes suivantes :

ipconfig /release
ipconfig/renew

Vérifie aussi que les deux machines sont dans le même vmnet, et regarde aussi les logs sur ta debian !


Messages postés
35
Date d'inscription
dimanche 31 octobre 2004
Statut
Membre
Dernière intervention
17 août 2011
1
voilà les lignes à décommenter(enlever les #) et à modifier dans le fichier dhcpd.conf :

authoritative;
subnet 192.168.0.0 netmask 255.255.255.0 {
range 192.168.0.10 192.168.0.100;
option routers 192.168.0.1;
}

NB:
1ere ligne: le serveur fait autorité sur le réseau
2eme: réseau et masque de sous réseau
3eme passerelle
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
Mes 3 VM (c'est à dire les deux clients XP et mon serveur Debian) sont en connexion par pont.
Voici le contenu de mon fichier dhcpd.conf :

#This is a very basic subnet declaration
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.50 192.168.1.60;

Je n'ai pas mis de passerelle car les 3 VM se trouvent sur la même machine physique, en l'occurrence mon PC portable.

Sur mes 2 VM XP dans propriétés TCP/IP j'ai renseigné l'adresse du DNS dans DNS préféré (192.168.1.1).

J'ai ajouté 192.168.1.1 dans la liste des serveurs DNS (bouton configuration avancée puis onglet DNS) et j'ai mis rosea-phoenix.org dans la case "suffixe DNS pour cette connexion"

Seulement, lorsque je fais ipconfig /renew sur ma 1ère VM XP la même adresse m'est redonnée sans problème(toujours la même adresse d'ailleurs je ne sais pas si c'est normal). En revanche sur la 2ème VM XP la commande ipconfig /renew me revoie un message d'erreur me disant qu'il ne peut contacter le serveur DHCP.

J'ai aussi essayé de rajouter authoritative dans le fichier dhcpd.conf mais ça n'a rien changé ce qui donne :

#This is a very basic subnet declaration
authoritative
subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.50 192.168.1.60;
Messages postés
62
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
5 septembre 2014
5
bonjour
peut etre iptables sur ton serveur dhcp
sur les postes xp, t'as pas besoin d'indiquer quoi que ce soit, il faut tout mettre en auto
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
merci tout fonctionne maintenant
Messages postés
62
Date d'inscription
mercredi 31 août 2011
Statut
Membre
Dernière intervention
5 septembre 2014
5
c'etait quoi le probleme qu'on en profite
Messages postés
100
Date d'inscription
mercredi 16 juin 2010
Statut
Membre
Dernière intervention
18 janvier 2016
31
A vrai dire je ne sais pas trop j'ai fais un ipconfig /renew sur mes 2 VM et ça a fonctionné. Je ne comprends pas je n'ai rien changé a la config ip.

C'est bizarre mais bon tant mieux.
bonjour,
Pourrais-tu m'aider je dois configurer les serveurs suivant: DNS, DHCP sur linux (centos ou debian). Merci c'est urgent