[Kubuntu] arrêter le serveur X

[Résolu/Fermé]
Signaler
Messages postés
75
Date d'inscription
jeudi 29 septembre 2005
Statut
Membre
Dernière intervention
16 mai 2013
-
 tiji -
Bonjour,

J'ai récamment voulu installer les drivers pour ma carte graphique (NVidia GeForce 2 MX). Jusque là les drivers n'étaient pas installés. J'ai téléchargé les drivers sur le site officiel de NVidia.

Le problème, c'est que lors de l'installation des drivers, j'ai une erreur et ça me dit que je dois arrêter le serveur X pour faire l'installation.
Je passe donc sur le terminal tty1 et je relance l'installation du driver. J'ai toujours le même message.
Donc je retourne sur tty7 (là ou il y a le serveur X de lancé) et je fais ctrl+alt+backspace (je sais, je suis un bourin). Le problème c'est que le serveur X se relance automatiquement et immédiatement. Je ne sait pas comment l'arrêter "définitivement pour la session".

Je vous remercie par avance pour votre aide.

PS : j'ai essayé de faire init 3 en su sur tty1 et ça ne marche pas.

7 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 562
Salut,

/etc/init.d/gdm stop

ou

/etc/init.d/kdm stop

ou

/etc/init.d/xdm stop

Je suppose que c'est kdm vu que tu es sous kubuntu.

lami20j
4
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 888
Salut,

Ton gestionnaire de session doit être configuré pour démarrer automatiquement le mode graphique.
Édite le fichier "/etc/inittab" et remplace le "5" de "id:5:initdefault:" par un "3" :
id:3:initdefault:
et reboote ton système, normalement tu devrais te retrouver en mode console.
Après avoir installer tes drivers, refais la même opération et remplace alors le "3" par un "5".
Le tout en tant que "root".
Petit rappel, sous "kubuntu" (ubuntu/xubuntu), l'appel du root se fait à l'aide de :
sudo commande
;-))
Messages postés
255
Date d'inscription
samedi 11 juin 2005
Statut
Membre
Dernière intervention
18 novembre 2006

'init 3' ou 'init3' (je ne sais jamais!!), en su - je crois...
Messages postés
75
Date d'inscription
jeudi 29 septembre 2005
Statut
Membre
Dernière intervention
16 mai 2013
9
Lorsque je fais 'init 3', j'ai :

#init 3
Switching to runlevel: 3
Stopping anac(h)ronistic cron : anacron
Starting anac(h)ronistic cron : anacron


Mais il ne se passe rien d'autre de spécial et le serveur X marche toujours.
Messages postés
75
Date d'inscription
jeudi 29 septembre 2005
Statut
Membre
Dernière intervention
16 mai 2013
9
J'ai d'abord voulu essayer la technique de jipici, mais lorsque je suis allé dans /etc/inittab, j'ai eu une surprise. Il n'y a pas
id:5:initdefault:

mais
id:2:initdefault:

Comme ce n'est pas vraiment ce à quoi je m'attendais je n'ai pas osé modifier. Je suis donc passé à la technique de lami20j.
J'ai fait
/etc/init.d/kdm stop

Et là, ça marche. Alors je dis un grand merci à lami20j (et mickmick et jipici aussi).

Bonjour, moi je suis sous ubuntu et je fais /etc/init.d/gdm stop après avoir fait ctrl alt f1
sauf que j'ai toujours le même prob quand j'essai d'installer mes drivers NVIDIA : " X server is running ... "
On dirait que gdm stop ne tue pas le X server... j'ai aussi essayé killall X sans résultats...
Quand tu te logg, vas dans option et logg toi avec la console de secour...----chu pas sur mais moi ca a marché...

Bonne chance...........