Menu déroulant + données associées

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
vendredi 22 juillet 2011
Statut
Membre
Dernière intervention
24 juillet 2011
-
Messages postés
378
Date d'inscription
vendredi 29 avril 2011
Statut
Membre
Dernière intervention
31 décembre 2011
-
Bonjour à tous,

J'aurais besoin e vos conseils pour combler un manque de connaissance Excel, et dans les forums, je ne trouve pas trop la solution.

J'ai créé un menu déroulant avec un certain nombre de produit dans une cellule, puis dans la cellule d'à côté, je souhaiterai qu'une valeur s'affiche en fonction du nom du produit du menu déroulant, mais ca ne marche pas, enfin les valeurs ne changent pas automatiquement quand je change de produit dans le menu déroulant...

Pouvez vous m'aidez s'il vous plait??

Merci beaucoup !

tib


5 réponses

Messages postés
378
Date d'inscription
vendredi 29 avril 2011
Statut
Membre
Dernière intervention
31 décembre 2011
127
Bonjour,

En supposant que A1 contient la valeur sélectionnée à l'aide d'une liste déroulante et B1, la valeur à modifier. Une solution consisterait à utiliser la fonction RECHERCHEV()

En B1 saisissez la formule suivante :
=RECHERCHEV(A1;"Coordonnées de votre source de données";"Numéro de a colonne recherchée).

Si cette solution ne fonctionne pas, pouvez-vous détailler votre besoin et déposer votre fichier sur www.cijoint.fr (sans données confidentielles), puis poster le lien ici?

Bonne soirée,
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
54348
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 août 2021
16 338
Botiskite, excuse-moi de te dire que ta formule est hautement fantaisiste, car tu n'as pas du tout respecté la syntaxe, qui est
RECHERCHEV(valeur_cherchée;table_matrice;no_index_col;valeur_proche)

Or ta formule en E3 est =RECHERCHEV(D3;B3:B18;A3:B3) dans laquelle
* seul le premier argument D3 est correct ;
* la table matrice est fausse, car elle ne contient qu'une colonne ; il fallait choisir comme argument A3:B18 ;
* le numéro d'index de colonne est faux ; il s'agit de la deuxième colonne de la matrice A3:B18, donc il faut saisir l'argument 2 ;
* la valeur_proche manque ; il faut ajouter le quatrième argument FAUX (ou 0).
La bonne formule est donc =RECHERCHEV(D3;A3:B18;2;FAUX).

Et comme ça, "la valeur change automatiquement" !

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
54348
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
5 août 2021
16 338
Je m'excuse auprès de Syzygy et des autres lecteurs de cette discussion : J'ai répondu sans me rendre compte que quasiment la même explication avait déjà été fournie depuis 23:52 ...

Finalement je n'ai pas supprimé mon post de 02:44 car la façon de présenter les choses n'est pas identique, et Botiskite pourra surfer entre les deux ; mais surtout Syzygy a zappé le dernier argument, ce qui peut avoir des conséquences facheuses si la première colonne de la matrice n'est pas triée ...

Salutations à vous tous.
Messages postés
3
Date d'inscription
vendredi 22 juillet 2011
Statut
Membre
Dernière intervention
24 juillet 2011

Bonjour à vous,

Merci beaucoup Syzygy et Raymond pour votre aide, vous êtes top...
Je commence à comprendre certaines choses mais mon tableau n'est pas fini, alors si besoin je reviendrais vers vous ;-)

Merci beaucoup
bonne fin de we !
Messages postés
378
Date d'inscription
vendredi 29 avril 2011
Statut
Membre
Dernière intervention
31 décembre 2011
127
Bonsoir,

Si la réponse résout votre problème, n'hésitez pas à passer ce post en résolu.

A bientôt sur le forum

Merci
Messages postés
378
Date d'inscription
vendredi 29 avril 2011
Statut
Membre
Dernière intervention
31 décembre 2011
127
Bonjour Raymond,

Il n'y a aucun soucis, il est vrai que j'ai omis de parler du dernier argument qui s'avère plus que nécessaire, (j'ai l'habitude d'avoir une liste triée).

Personnellement, j'ai d'ailleurs tendance à ne pas utiliser la formule "RECHERCHEV" mais le duo "INDEX-EQUIV". Dans ce cas de figure, cela donnerait :

=INDEX(A3:B18;EQUIV(D3;A3:A18;0);2)

Bonne journée
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
vendredi 22 juillet 2011
Statut
Membre
Dernière intervention
24 juillet 2011

Merci pour ta réponse rapide mais je n'y arrive toujours pas...
j'ai fait comme tu m'as dit avec le lien ci dessous:

http://www.cijoint.fr/cjlink.php?file=cj201107/cijmWT6CqB.xls

En fait, quand je sélectionne le "type" dans le menu déroulant, je souhaiterai que dans la cellule d'à côté, le prix s'affiche.

ex: pour le produit type 10, le prix de 489 euros devrait s'afficher automatiquement

merci beaucoup si tu sais comment faire
et m^me si tu ne sais pas ;-)
Messages postés
378
Date d'inscription
vendredi 29 avril 2011
Statut
Membre
Dernière intervention
31 décembre 2011
127
J'ai retravaillé la formule en E3 il faut saisir :

=RECHERCHEV(D3;A3:B18;2)

Le premier critère : D3 est la valeur recherchée, jusque là aucun problème.

Le deuxième critère représente la matrice où Excel devra effectuer la recherche et qui contient les résultats à afficher (la source de données en fait). La source de donnée représente non seulement la zone ou Excel effectuera la recherche mais également les valeurs que tu souhaites afficher

Le troisième critère représente le numéro de colonne de la matrice qui contient les valeurs que l'on souhaite afficher.

Si mes explications ne sont pas très claires (et y a des chances pour que ce soit le cas), n'hésite pas à consulter l'aide d'Excel (touche F1) qui est très complète à ce sujet.