Copier ligne deux tableaux Excel 2007

Résolu/Fermé
Signaler
-
 Macro difficile -
Bonjour à tous,
Je viens vers vous pour m'éviter de galérer pendant des heures pour rien.

Je dispose de deux tableaux qui ont en commun une colonne nommée « Nom de Famille », cependant le tableau 1 contient 398 noms et le deuxième contient 59 noms.

Mon objectif est de copier la ligne entière du tableau 2 à droite du tableau 1 en fonction du nom (lorsque ceux-ci sont identiques).

Je vous donne un exemple simplifié :

Tableau 1

Nom de famille Pièce Qualité Vente
DUPONT 123 1 15
DURAND 52 3 26
BERNIDO 258 8 220
ALVES 589 2 356
JOUILER 256 7 111
BUTAZER 2585 2 2222

Tableau 2

Nom de famille Solde
DUPONT 123
JOUILER 256
BERNIDO 2

Résultat attendu

Nom de famille Pièce Qualité Vente Solde
DUPONT 123 1 15 123
DURAND 52 3 26
BERNIDO 258 8 220 2
ALVES 589 2 356
JOUILER 256 7 111 256
BUTAZER 2585 2 2222

Je n'arrive pas à faire comprendre à la macro qu'elle doit analyser la colonne du tableau 1 et la colonne du tableau 2 et de copier que lorsqu'elles sont identiques.

Merci d'avance.

4 réponses

Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
bonjour,

Pourquoi une macro?

avec une simple rechercheV.... ou alors, j'ai mal compris ta demande
0

Une recherche v pourquoi pas mais je n'arrive pas à savoir comment rédiger la fonction. C'est pourquoi j'ai pensé à la macro.

Pour etre plus claire j'ai réécrit les tableaux

Tableau 1 sur la feuille 1
Nom Pièce Qualité Vente
ALVES 589 2 356
BERNIDO 258 8 220
BUTAZER 2585 2 2222
DUPONT 123 1 15
DURAND 52 3 26
JOUILER 256 7 111

Tableau 2 sur la feuille 2
Nom Solde
BERNIDO 2
DUPONT 123
JOUILER 256

Résultat attendu sur la feuille 1
Nom Pièce Qualité Vente Solde
ALVES 589 2 356
BERNIDO 258 8 220 2
BUTAZER 2585 2 2222
DUPONT 123 1 15 123
DURAND 52 3 26
JOUILER 256 7 111 256

Si vous pouvez me donner le libéllé de la fonction car je n'y arrive pas.

Merci.
0
Messages postés
16547
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 janvier 2022
3 260
Re,
colonne "solde" tableau 1
=SI(NB.SI(Feuil2!A$2:A$59;A2)=0;"";RECHERCHEV(A2;Feuil2!A$2:B$59;2;0))
à tirer vers le bas


demo:
https://www.cjoint.com/?3GopCaHWZke
0

Effectivement, c'est beaucoup plus simple par ce biais.

Merci beaucoup, je vais mettre en oeuvre cette solution.

Merci pour la démo, j'ai pu comprendre le cheminement.

Bonne fin de journée.
0