Excel, Somme des cellules jaune

[Résolu/Fermé]
Signaler
-
Messages postés
54882
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour tout le monde,

Ca fait une journee que j essaie de trouver une solution pour additionner de maniere automatique les valeurs accompagnees par une etoile.
Dans l exemple suivant, j aimerai addtionner 125, 25, 25, et 50.

125*
to be reviewed
25*
275
375
to be reviewed
900
400
25
2800
25*
200
to be reviewed
50*
to be reviewed

Merci d avance pour votre aide,

Jean Philippe



2 réponses

Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
Bonjour

par une fonction personnalisée

 Sub test()
   MsgBox additionner_si_etoile(Range("A1:A14"))
End Sub

'-------
 Function additionner_si_etoile(plage As Range) As Double
Dim cellule As Range, pos As Byte
For Each cellule In plage
    pos = InStr(cellule, "*")
    If pos > 0 Then
          somme = somme + CDbl(Left(cellule, pos - 1))
     End If
Next
additionner_si_etoile = somme
End Function


Messages postés
3
Date d'inscription
jeudi 14 juillet 2011
Statut
Membre
Dernière intervention
14 juillet 2011

Je ne comprends pas. Voici le veritable fichier.

Il faut que j additionne 50*, 125*, 25*, 25* de maniere automatique

15660001 PWI P 7642/2 WHP -H- 725
15660101 PWI L 7642/2 WHP -H- 1300
15664601 PBH P 5351/2 RED -H- 50
15671501 PBH P 7611/4 GNP -H- to be reviewed
15671601 PBH L 7611/4 GNP -H- 50*
15672901 PBH L 7649/2 PIP -H- 225
15673901 PBH P 7645/2 PIP -H- 125*
15674200 PBH P 74946/2 PIP to be reviewed
15674201 PBH P 74946/2 PIP -H- 25*
15674901 PBH P 7603/2 PIP -H- 275
15675401 PBH P 7598/2 PIP -H- 375
15748701 PBH G 72223/4 BUP -H- to be reviewed
15770401 PWI 7491 WHP -H- 900
15803801 PBH PTE 11058/2 ST ORE -H- 400
15803901 PBH PTE 4633 BUE -H- 25
15849401 PBH L 7454/2 BKP -H- 2800
15853401 PBH P 7628/2 BUP -H- 25*
Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
sans VBA avec une matricielle

=SOMME(SI((NON(ESTERREUR(TROUVE("*";A1:A15))));CNUM(GAUCHE(A1:A15;TROUVE("*";A1:A15)-1))))

Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule; Excel encadre alors automatiquement la formule par des {}
renvoie 225 avec tes données
Messages postés
3
Date d'inscription
jeudi 14 juillet 2011
Statut
Membre
Dernière intervention
14 juillet 2011

J ai excel en anglais,
Encore Merci
Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
Il faut bien te rendre compte que ce que tu demandes n'est pas forcément facile et que personne ne veut passer parfois plusieurs heures à essayer de résoudre un problème bénévolement pour se voir dire après coup « non vous n'avez pas compris mon problème (rarement, Excusez moi,je n'ai pas bien expliqué), il faut en plus que...., j'ai un excel en anglais.... »

Abandon du suivi
Messages postés
3
Date d'inscription
jeudi 14 juillet 2011
Statut
Membre
Dernière intervention
14 juillet 2011

Je m excuse si j ai paru mal polis, ce n etait le but.
La matricielle que tu m a donne fonctionne a merveille. Je te remercie dc enormement.
Bravo pr ta connaissance de ce logiciel. c impressionnant.

Merci pr ton aide
Messages postés
54882
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 777
Pourquoi as-tu intitulé ta discussion "Somme des cellules jaunes", alors que ton exemple contient des chiffres accompagnés d'une étoile (ce qui les transforme en textes et empêche tout calcul direct) ?
Messages postés
54882
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 777
et comme on le demande à tous ceux qui posent des questions : Envoie-nous un lien pour qu'on puisse ouvrir ton fichier !
Bonjour Raymond,

J ai utilise cette intitule car les cellules que je veux additionner (celle contenant des etoiles) sont aussi de couleurs jaune. Mais j ai pense que ce n etait pas pertienent.
Messages postés
54882
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
16 777
Alors
- utiliser la colonne D pour insérer un caractère distinctif signalant les nombres à totaliser ;
- éviter l'étoile, le slash, le signe égal, le point d'interrogation ; leur préférer la lettre x ;
- saisir en C25 la formule =SOMME.SI(D$1 :D$23;"x";C$1:C$23) pour totaliser les cellules concernées ;
- utiliser la Mise en Forme Conditionnelle pour qu'Excel remplisse en jaune les cellules à gauche de "x".
https://www.cjoint.com/?AGoqTyQWQzb