EXCEL : supprimer données après un espace

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
dimanche 29 novembre 2009
Statut
Membre
Dernière intervention
4 juillet 2011
-
Messages postés
3
Date d'inscription
dimanche 29 novembre 2009
Statut
Membre
Dernière intervention
4 juillet 2011
-
Bonjour à tous,

Je suis vraiment débutant sur Excel. Je cherche une commande qui permettrait de supprimer, ou séparer des données qui se situent après un espace.

En fait il s'agit d'obtenir le premier prénom d'une cellule qui contient les trois prénoms.

Exemple : ADRIEN PHILIPPE PAUL
Je souhaiterais : ADRIEN

Je parie que ce n'est pas compliqué, mais j'ai besoin de votre aide.

Merci à tous !

Ben

A voir également:

2 réponses

Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 252
bonjour,

sans vba tu peux les séparer tout simplement par la commande "données convertir"
toujours sans Vba formule donnant le premier prénom
=GAUCHE(A2;CHERCHE(" ";A2)-1)

avec vba fonction personnalisée
Function prenom1(cellule As Range) As String
prenom1 = Split(cellule)(0)
End Function

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
dimanche 29 novembre 2009
Statut
Membre
Dernière intervention
4 juillet 2011

Merci beaucoup Michel pour ton aide.
Alors la première commande marche impec. Simplement, elle n'est pas contente et me met "#valeur" lorsqu'il n'y a qu'un prenom dans le cellule de "base"...
Je vais tenter la vba même si je ne sais pas bien comment faire ;-)

Ben
Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 252
Il aurait été judicieux de préciser que tu pouvais avoir de 0 à N prénoms...je n'ai que ce que tu écris pour essayer de t'aider

=SI(ESTERREUR(CHERCHE(" ";A2));A2;GAUCHE(A2;CHERCHE(" ";A2)-1))
Messages postés
3
Date d'inscription
dimanche 29 novembre 2009
Statut
Membre
Dernière intervention
4 juillet 2011

Merci Michel, ça marche impec. Vous êtes mon sauveur !

Amitiés