Lien hypertexte en fonction valeur cellule [Fermé]

Signaler
-
Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
-
Bonjour,


Je suis un peu perdue et ne sais comment m'y prendre...si quelqu'un a une solution pour moi, je la prend avec plaisir!
Voila :
j'ai un fichier excel avec plusieures feuilles:
sur une feuille, je vais rentrer l'affectation de telle parcelle à telle cuve... et ce que j'aimerai faire c'est qu'en fonction du numéro de cuve attribuées ( de 1 à 9) je puisse créer un lien hypertexte qui m'enverrait directement dans la feuille correspondant à la bonne cuve...
en gros en, fonction de la valeur d'une cellule, affecter un lien hypxtexte différent (vers le meme classeur, mais pas la meme feuille).

Merci bq de votr aide!!!

3 réponses

Messages postés
16174
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
6 août 2020
3 000
bonjour

tu sélectionne ta cellule où tu veux mettre le lien et regarde
https://www.cjoint.com/?3FEo17QcLGF
Messages postés
16174
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
6 août 2020
3 000
si en A15 par ex, j'écris 2009 ce lien hypertexte ouvre la feuille 2009 des résultats au scrabble

..\..\..\..\resultats_scrabble.xls#'&A15&"'!A1"
Messages postés
1823
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
24 avril 2020
578
Bonjour CLairede et michel_m

s'il s'agit de faire un test par rapport à une cellule pour orienter vers un lien différent voici un exemple de formule :

=LIEN_HYPERTEXTE(SI(A1=1;"[Classeur1]Feuil2!A1";"[Classeur1]Feuil3!A1");"Texte en clair du lien")

Si A1=1 le lien désigne Feuil2 sinon Feuil3


A adapter

A+

Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
211
Bonjour,

exemple avec B5=1 envoi vers la feuille cuve1

=SI(ESTNUM(B5);SI((ET(B5>0;B5<10;ENT(B5)=B5));LIEN_HYPERTEXTE(CONCATENER("cuve";B5;"!A1");CONCATENER("cuve";B5));"");"")

suggestion:
mettre une liste de validation pour B5 (chiffres de 1 à 9) et simplifier la formule
=SI(B5<>"";LIEN_HYPERTEXTE(CONCATENER("cuve";B5;"!A1");CONCATENER("cuve";B5));"")

Le pinard ça devrait être obligatoire.