Excel:Meme nombre de chiffre dans une colonne [Résolu/Fermé]

Signaler
-
Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
-
Bonjour,

J'ai récupéré un fichier Excel dans lequel je devrais avoir des nombres composés de 7 chiffres pas plus, pas moins dans la colonne A. Le problème est que certains sont composés de 4, 5 ou 6 chiffres.

Par exemple:

123456 alors qu'il faudrait 1234560
12340 alors qu'il faudrait 1234000
1234 alors qu'il faudrait 1234000

Je dois donc rajouter 1,2 ou 3 zéros après pour que ces nombres soient composés de 7 chiffres.

Vous imaginez bien que manuellement, sur plusieurs ligne et fichiers, on ne s'en sortirait pas!

Pouvez-vous m'aider?

Merci d'avance!

4 réponses

Messages postés
235
Date d'inscription
mercredi 19 avril 2006
Statut
Membre
Dernière intervention
1 juin 2012
1
bonjour,

dans tn fichier d'origine tous tes nbres ont 7 chiffres?

Non, dans le fichier d'origine, certains ont 7 chiffres d'autres 6,5 ou 4. Ils me l'ai faut tous à 7 chiffres avec des 0 derrières.

Merci!

Les 0 à rajouter sont pour ceux qui ont moins de 7 chiffres. si j'ai 1234567, là je n'y touche pas. Sinon 123456, là je lui rajoute un 0.

Merci!
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 293
Salut,

pour avoir absolument 7 chiffres et ajouter des 0 s'il en manque
sélectionne tes cellules, clique droit, format de cellule, personnalisé et tu mets 0000000 de cette façon tu auras
0123456
00001234

J'ai déjà essayé mais ça ne marche pas. Bizare. Mais de toute façon, cela aurait mis les 0 devant et il me l'ai faut derrière...

Merci!
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 293
La logique veut que les 0 soient devant non?
si tu as 100 dans ta cellule et que tu ajoute un 0 derrière alors la valeur devient 1000 et non 100, alors que si tu mets le 0 devant la valeur reste 100

Ce sont des numéros de comptes, de classes en compta. Ex: le compte 401 Fournisseurs ou 4010000 Fournisseurs. C'est pareil. Mais pour le logiciel, dans lequel je dois insérer mon fichier Excel, il a besoin de 7 chiffres pas moins, sinon ca ne fonctionne pas.

Merci.
Messages postés
235
Date d'inscription
mercredi 19 avril 2006
Statut
Membre
Dernière intervention
1 juin 2012
1
bonjour


123456 =NBCAR(G5) =SI(H5=6;G5*10;) =NBCAR(I5)
12340 =NBCAR(G6) =SI(H6=5;G6*100;) =NBCAR(I6)
1234 =NBCAR(G7) =SI(H7=4;G7*1000;) =NBCAR(I7)
=NBCAR(G8) =NBCAR(I8)
12340 =NBCAR(G9) =SI(H9=6;G9*10;SI(H9=5;G9*100)) =NBCAR(I9)
un petit exemple
si cela peux te rendre service

christian
Messages postés
235
Date d'inscription
mercredi 19 avril 2006
Statut
Membre
Dernière intervention
1 juin 2012
1
re
nb car avant resultat nb car apres

123456 6 1234560 7
12340 5 1234000 7
1234 4 1234000 7
0
1234 4 1234000 7

si c'est ce que tu cherches je t'envoie le modele par cijoint

dis moi

christian

C'est bon, tu m'a guidé! J'ai trouvé:

Je trie ma colonne du plus petit au plus grand. Je me créé une nouvelle colonne avec : =A1*10 et j'étends la formule à tous les nombres à 6 chiffres puis je remplace mes résultats par mes nombres à 6 chiffres. Je fais x100 pour les cellules de nombres à 5 chifres et *1000 pour ceux de 4 chiffres. Après je remets dans l'ordre!

Merci!
Messages postés
235
Date d'inscription
mercredi 19 avril 2006
Statut
Membre
Dernière intervention
1 juin 2012
1
re

je serais absent en debut d'apres midi...voici le lien si cela t'interesse
http://www.cijoint.fr/cjlink.php?file=cj201106/cijeG60yt9.xls
Messages postés
25366
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
5 521
Bonjour
pour faire simple:
si le nombre à toujours 7 caractères ou moins de 7
pour une celle A1 en B1:
=A1&REPT(0;7-NBCAR(1))
donnera toujours 7 chiffres en complétant avec des 0 (résultat en format texte)


Crdlmnt

Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?