Excel- reproduire formule une colonne sur 2

Résolu/Fermé
moomine Messages postés 42 Date d'inscription lundi 20 juin 2011 Statut Membre Dernière intervention 16 janvier 2012 - 20 juin 2011 à 11:16
moomine Messages postés 42 Date d'inscription lundi 20 juin 2011 Statut Membre Dernière intervention 16 janvier 2012 - 20 juin 2011 à 12:00
Bonjour,

Voila, j'ai un fichier excel, en colonne B, la liste des prix. En colonne A, la liste de mes produits.
En colonne C,E,G... une colonne sur deux: j'ai la quantite de mes produits
En colonne D,F,H... une colonne sur deux: j'ai le total de la valeur de mes produits

La formule pour D3 est donc =C3*B3 (quantite de produit * prix unitaire)

Ensuite, je peux faire un copier coller vers le bas, qui donnera automatiquement pour la cellule D4==> =C4*B4

Apres, j'ai parfois des "N/A" qui s'affiche; car certains produits n'existe plus dans le fichier... alors pour eviter de voir les N/A, j'ajoute le formule =SI(ESTNA...

Resultat, la formule devient: =SI(ESTNA(C3*B3);0;(C3*B3))

Maintenant, j'aimerais copier cette formule une colonne sur deux... tout en bloquant la cellule B3 car il faut toujours prendre la colonne des prix unitaires.

Pourriez vous m'aider si quelqu'un connais la reponse. merci.


A voir également:

5 réponses

chossette9 Messages postés 4239 Date d'inscription lundi 20 avril 2009 Statut Contributeur Dernière intervention 12 septembre 2014 1 308
20 juin 2011 à 11:46
Bonjour, pour le reproduire une fois sur deux, écrire la formule en D3, sélectionner les cellules D3 et E3, cliquer sur le bas de la cellule E3 à droite (sur le petit carré), et glisser. La formule sera copiée une colonne sur 2.

Cordialement.
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
20 juin 2011 à 11:37
Bonjour tous
si je peux me permettre,Mélanie:
le $ devant le n° de ligne bloque la ligne,non?
il faudrait vu la demande écrire:
$B3 pour conserver les colonnes.
Un peu de brumes du lundi?
crdlmnt
melanie1324 Messages postés 1505 Date d'inscription vendredi 25 mai 2007 Statut Membre Dernière intervention 31 janvier 2018 154
20 juin 2011 à 11:24
Bonjour,

pour bloquer la colonne B3 :

=SI(ESTNA(C3*B$3);0;(C3*B$3))

Normalement, si tu copies sur lignes : toujours la colonne B mais la ligne s'adapte
si tu copies sur colonne : les autres colonnes s'adaptent mais la colonne B ne bouge pas.
moomine Messages postés 42 Date d'inscription lundi 20 juin 2011 Statut Membre Dernière intervention 16 janvier 2012 2
20 juin 2011 à 11:42
oui, je connais la formule avec le signe du dollar

ma formule devient donc:
=SI(ESTNA(C3*B$3);0;(C3*B$3))

cependant, je voudrais copier cette formule sur toute la ligne mais seulement une colonne sur deux...

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
moomine Messages postés 42 Date d'inscription lundi 20 juin 2011 Statut Membre Dernière intervention 16 janvier 2012 2
20 juin 2011 à 12:00
ah super. merci chosette9, vraiment pas bete. Je connaissais l'astuce pour coller vers le bas ou vers la droite mais je n'avais pas pensé a selectionner les 2 cellules pour que la formule se reproduise qu'une fois sur deux.

Du coup j'ai fait comme tu m'as suggerer pour copier une fois sur deux sur toute la ligne, et ensuite j'ai utiliser la meme astuce pour tout copier vers le bas.

Merci!

Et merci aussi a melanie1324 et Vaucluse pour vos reponses.