Calcul avec excel

Résolu/Fermé
melissa84860 - 7 juin 2011 à 19:11
 melissa84860 - 9 juin 2011 à 15:47
Bonjour,

Voilà j'aurais voulu savoir comment faire le total de nombre negatif. En obtenant un nombre negatif bien entendu.

Par exemple j'ai 1000 cellule a -8, -0.2;-0.5;-0.60;-2 comment je fais pour toutes les additionner .
A voir également:

2 réponses

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 403
7 juin 2011 à 19:43
Bonsoir
Il suffit e faire la somme ds cellules.
Facile si les 1000 sont dans le même champ:
=SOMME(champ)
soit par exemple:=SOMME(A1:B500)
mais s'il est ne sont pas contiguës:
=SOMME(champ1)+SOMME(champ2) etc....
en espèrant pour vous qu'elles ne sont pas toutes isolées
si vous avez des cellules positives et négatives et que vous ne voulez que la somme des négatifs:
=SOMME.SI(Champ;"<0";Champ)

crdlmnt
0
melissa84860
7 juin 2011 à 19:52
Cela ne marche pas. J'ai essayer plusieurs trucs avec somme sommeprod somme.si mais le resultat est toujours le meme. J'obtient toujours 0.0000. Avez vous un autre solution?
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 403
7 juin 2011 à 19:57
Il n'y a aucune raison d'appliquer une autre solution, avec nombre positifs ou négatifs, pour faire une somme. Le problème vient eut être:
soit du formatage des cellules
soit du format du séparateur (point ou virgule)
soit des informations erronées sur les adresses de champ.
Pouvez vous mettre à disposition un modèle de votre problème pour que l'on voit ce qui se passe:
ici:
http://www.cijoint.fr
et revenez placer ici le lien donné par le site
A vous lire
0
melissa84860
7 juin 2011 à 20:02
http://www.cijoint.fr/cjlink.php?file=cj201106/cij56dZ2ua.xls

voila
0
melissa84860
7 juin 2011 à 20:07
dite moi si je me trompe mais peut-etre que j'ai trouvé la solution.

Apparament ca fonctionne avec cette formule =SOMMEPROD(-(B1:B243>0))
C'est possible?
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 403
Modifié par Vaucluse le 7/06/2011 à 20:32
J'ai chargé votre fichier.
Avec mon excel, il faut que je transforme le séparateur en virgule car il n'accepte pas le point

quant à la formule que vous donnez, excel renvoi 0 avec la virgule et -97 avec le point.
en fait elle ne fait pas la somme, mais compte le nombre de ligne de la colonne B avec une valeur et donne le résultat en négatif.
Je ne crois pas que ce soit la solution.!!!

Par contre:
effectivement une formule SOMME sur votre fichier en l'état renvoi 0

par compte, une fois que j'ai placé les virgules, une simple formule:
=SOMME(B:B) me renvoi le résultat, soit -66,26, ce qui parait plus juste.

Alors je ne sais pas comment est formaté votre excel, mais le point ne doit pas être le bienvenu la dedans à la place de la virgule.

Essayez ceci:
sélectionnez toute la colonne B
selon votre excel:
soit barre d'outil / Edition/ Remplacer
soit ruban / Accueil /et rechercher et remplacer
cliquez sur remplacer
en haut entrez le point
en bas la virgule et OK
voyez alors ce que donne la formule SOMME au plus simple.

Si cela fonctionne, on suppose que vos données viennent d'un excel formaté différemment, alors:
_soit vous admettez de les corriger comme ci dessus pour remplacer le point.
_soit vous changez le séparateur, et je ne suis pas sur que cela suffise, vu que certaines données pourraient rester en texte (alignées à gauche dans les cellule) lorsqu'on sélectionne l'allègement horizontal "standard"

crdlmnt
0
Raymond PENTIER Messages postés 58495 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 13 juin 2024 17 130
7 juin 2011 à 21:52
Bonjour Mélissa.

Il te suffit d'appliquer la manipulation #6 de Vaucluse du 7 juin à 20:30

En effet tu as saisi (ou importé) des données en format texte !
0