[LAMP-Ubuntu] Xampp [Résolu/Fermé]

Signaler
Messages postés
1867
Date d'inscription
vendredi 15 avril 2005
Statut
Membre
Dernière intervention
24 juillet 2014
-
 Daiv -
Bonjour,

J'ai installé XAMPP comme solution LAMP pour développer en XHTML/CSS/PHP/MySQL

Mais voilà, dès les premiers tests, le CSS ne fonctionne pas.

Savez-vous si cela est normal (s'il ne le fait pas) ? J'ai cherché sur la DOC, mais il n'y a pas mention de CSS :s

Merci d'avance.

Config : Ubuntu Breezy

4 réponses

Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 543
Salut,

je ne comprends pas exactement ce que tu veux.

CSS - Cascading Style Sheet
https://fr.wikipedia.org/wiki/Feuilles_de_style_en_cascade

tu peux editer un fichier html ou .css qui contient du CSS avec un editeur de texte sans mise en forme (vi, emacs)

lami20j
Messages postés
1867
Date d'inscription
vendredi 15 avril 2005
Statut
Membre
Dernière intervention
24 juillet 2014
335
Salut lami20j,

Tout d'abord merci, mais je viens de résoudre mon problème.

En fait, pardon si je n'ai pas été clair, je voulais monter un serveur LAMP. J'ai donc installé XAMPP.
Mais le problème était que les pages s'affichaient sans Style (sans tenir compte des fichiers CSS).

En fait c'était un problème de droit d'accès, le serveur ne pouvait pas y accéder tout simplement.
$ chmod -Rv 777 * et c'est résolu

Sinon une petite question portant sur un autre sujet :
Comment faire pour que Ubuntu m'ouvre par défaut les .php avec Gedit (éditeur de texte)? J'ai sélectionné le programme Gedit dans 'ouvrir avec' , mais il ne m'autorise pas à ouvrir Gedit lorsque je clic sur le fichier.php car il dit que c'est trop dangereux :( je suis obligé d'ouvrir l'éditeur et Fichier/ouvrir......

Merci d'avoir répondu :) bye
Messages postés
21331
Date d'inscription
jeudi 4 novembre 2004
Statut
Modérateur, Contributeur sécurité
Dernière intervention
30 octobre 2019
3 543
Re,

En fait, pardon si je n'ai pas été clair
En effet, pas très claire mais ce n'est pas grave.
Le plus important c'est que tu as résolu ton problème.

Bonne soirée,

lami20j
Bonjour, J'ai installé XAMPP sous windows et j'ai le même problème. Les pages internet sont affichées sans prendre en compte les feuilles de style externes.

Deplus, quand je souhaite afficher ma feuille de style directement dans le navigateur, j'ai un message d'erreur XAMPP.
Je saisie l'adresse suivante : http://localhost/TM/_style.css
Voici le message d'erreur :
Objet non trouvé!
L'URL requise n'a pu etre trouvée sur ce serveur. Si vous avez tapé l'URL à la main, veuillez vérifier l'orthographe et réessayer. 

Si vous pensez qu'il s'agit d'une erreur du serveur, veuillez contacter le gestionnaire du site. 

Error 404
localhost
10/20/06 10:20:11
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 


Qulelqu'un peut-il m'aider ?