Transformation de variables sous Excel [Résolu/Fermé]

Signaler
-
 Sinuletpourtant -
Bonjour,

Je cherche à obtenir une nouvelle variable à l'aide de mes deux variables.

Je m'explique : j'ai à ma disposition une

-variable qualitative qui prend les valeurs "A","N","RD" etc...
-variable quantitative qui prend les valeurs 104, 4, 10 etc...

Je cherche à obtenir une variable de la forme : A0007, N0104, A0010 ... : c'est à dire les lettres + les chiffres codés sur 4 caractères (lorsqu'il n'y en a pas 4 il me faudrait des 0...)

Merci d'avance

2 réponses

Messages postés
1505
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
31 janvier 2018
131
Bonjour,

voici la formule :
=SI(NBCAR(B23&A23)<4;SI(NBCAR(A23)=1;SI(NBCAR(B23)=0;A23&"000";SI(NBCAR(B23)=1;A23&"00"&B23;SI(NBCAR(B23)=2;A23&"00"&B23;A23&B23)));SI(NBCAR(A23)=2;SI(NBCAR(B23)=0;A23&"00";SI(NBCAR(B23)=1;A23&"0"&B23;A23&B23));SI(NBCAR(A23)=3;SI(NBCAR(B23)=0;A23&"0";A23&B23))));A23&B23)

B23 est la cellule qui contient tes nombres
A23 est la cellule qui contient tes nombres
nbcar est formule comptant le nombre de caractères dans une cellule

Merci :) , c'est vrai qu'avec cet algorithme et la fonction nbcar (que je ne connaissais pas sur le coup) m'aurait permis de m'en sortir !
Messages postés
16258
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 octobre 2020
3 051
Bonjour

A1 la qualitative
B1 la quantitative

=A1&TEXTE(B1;"0000")

Simple et efficace, merci beaucoup !