Probleme d'affichage d'image de fond sur site

Résolu/Fermé
Signaler
Messages postés
39
Date d'inscription
mercredi 27 avril 2011
Statut
Membre
Dernière intervention
30 juillet 2012
-
Messages postés
445
Date d'inscription
samedi 3 avril 2010
Statut
Membre
Dernière intervention
3 novembre 2011
-
Bonjour, depuis 3 jours j'essaye de mettre une image de fond sur mon site mais l'image ne s'affiche pas !
Voila ce que j'ai écrit dans mon fichier CSS :

body
{
background-image: url("/image/Space.jpg");
}

Et l'image ( qui s'appele Space.jpg ) ne s'affiche pas !

Merci de votre aide.

8 réponses


t sur que l'url est bonne?

essaye sans les guillemets

sinon vérifie bien si ton fichier porte bien l'extension .css sa peut arriver de ce planter à ce niveau,donc peut-être que l'image n'es pas apelée à cause de ça.
Messages postés
39
Date d'inscription
mercredi 27 avril 2011
Statut
Membre
Dernière intervention
30 juillet 2012

Oui Oui tout est bon mais sa ne veut pas s'afficher
Messages postés
445
Date d'inscription
samedi 3 avril 2010
Statut
Membre
Dernière intervention
3 novembre 2011
58
Peut-être que le body contient des éléments HTML dont le fond cache le body (couleur unie, autre image...). Ton site est-il en ligne, afin qu'on puisse y jeter un coup d'oeil ?
Messages postés
39
Date d'inscription
mercredi 27 avril 2011
Statut
Membre
Dernière intervention
30 juillet 2012

Nan désolé mon site n'est pas encore en ligne ;) Mais c'est pour bientot ;P

salut,
vérifie aussi qu'il existe ce dossier image, qu'il contient l'image.
-pour commencer tu mets une couleur comme background cela verifiera si le fichier css est bien inclus dans le site.
-puis tu vérifies les noms et les répertoires
Messages postés
39
Date d'inscription
mercredi 27 avril 2011
Statut
Membre
Dernière intervention
30 juillet 2012

Merci en fait le probleme c'est que j'avais mal codé un truc dans le fichier XHTML c'est pour sa que sa ne s'affichait pas ^^
Utilisateur anonyme
c'est bien ! signale que le problème est résolu
Tu peux nous décrire l'arborescence de ton répertoire ainsi que l'emplacement des ton fichier css, html et de ton image ?

Le chemin que tu donne dans ton fichier css se réfère à l'emplacement de ton fichier css et non pas à celui de la page html qui l'appelle...

Si on imagine une arbo dans le genre:

/
 - index.html
 - /images/
   -background.jpg
-/css/
  -style.css


Pour appeller le background.jpg depuis ton fichier css il faudrait faire:
background:url(../images/background.jpg)
Messages postés
445
Date d'inscription
samedi 3 avril 2010
Statut
Membre
Dernière intervention
3 novembre 2011
58
fais un ls -lR, puis un copier-coller