Formule Excel - Problème d' * [Résolu/Fermé]

Signaler
Messages postés
230
Date d'inscription
jeudi 19 novembre 2009
Statut
Membre
Dernière intervention
19 mai 2015
-
Messages postés
2404
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
27 novembre 2020
-
Bonjour,

Impossible de faire fonctionner le joker dans ma formule. La voici :

=SOMMEPROD(('sav201002'!$B$2:$B$3168=40607)*('sav201002'!$D$2:$D$3168="*NORD*"))

Pourtant sans les jokers (pour d'autre recherche), cette formule fonctionne parfaitement.

Impatient d'avoir votre aide, merci !

4 réponses

Messages postés
2404
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
27 novembre 2020
904
Remplacez ('sav201002'!$D$2:$D$3168="*NORD*") par
(ESTNUM(CHERCHE("NORD";'sav201002'!$D$2:$D$3168)))
Soit
=SOMMEPROD(('sav201002'!$B$2:$B$3168=40607)*(ESTNUM(CHERCHE("NORD";'sav201002'!$D$2:$D$3168)))))
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
2404
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
27 novembre 2020
904
Bonjour,
Regardez ce commentaire ça vous aidera un peu:
https://forums.commentcamarche.net/forum/affich-21999176-probleme-nb-si#15
Messages postés
230
Date d'inscription
jeudi 19 novembre 2009
Statut
Membre
Dernière intervention
19 mai 2015
19
Le problème est que je ne cherche pas à renvoyer VRAI :S
Messages postés
230
Date d'inscription
jeudi 19 novembre 2009
Statut
Membre
Dernière intervention
19 mai 2015
19
Merci beaucoup et désolé d'avoir douter de tes remarques. La prochaine fois, je me concentre plus. Encore merci !
Messages postés
2404
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
27 novembre 2020
904
Pas de problème: l'essentiel est de résoudre ;-)