Aide sur excel calcul avec 25 conditions !!

Fermé
Signaler
Messages postés
2
Date d'inscription
jeudi 28 avril 2011
Statut
Membre
Dernière intervention
28 avril 2011
-
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
-
Bonjour,
je cherche par quel formule je peux calculer des droit aux congés en fonction des absences maladie:

sachant que si de 0 à 36 jours d'absence maladie je donne 25 j, de 36 à 44 jours d'absence je donne 24 jours et ainsi de suite , et j'ai environ 25 conditions.
la fonction SI ne marche qu'avec 7 conditions.
Pouvez-vous m'aider.

merci.




2 réponses

Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
346
Il faut utiliser la fonction recherche.

Créer un tableau de 2 colonnes sur la feuille ou dans une nouvelle feuille.
Première colonne, inscrire les bornes basses des périodes,
Deuxième colonne, le nombre de jours de congés pour la période.
Faire une recherche verticale dans le tableau en fonction des jours d'absences.

Par exemple pour un tableau sur la même feuille :

de A1 à B25 (A/B) :
0/25
34/24
50/23
60/22
70/21
80/20
90/19
etc...

Si le nombre de jours d'absences est situé dans la cellule D2 et que vous souhaitez avoir le nombre de jours en D3, vous avez en D3 la formule suivante :
=RECHERCHEV(D2;A1:B25;2)

Cette formule recherche la valeur de D2 dans la colonne 1 du tableau, et renvoi en D3 la valeur trouvée dans la colonne 2.
Si la valeur trouvée est + grande que celle recherchée, la recherche s'arrête à la valeur numérique inférieure et renvoi la valeur correspondante de la colonne 2.
Messages postés
1088
Date d'inscription
samedi 26 novembre 2005
Statut
Membre
Dernière intervention
13 mai 2021
346
Bonjour,

après avoir posé la même question, le même jour sur 2 forums différents,
https://forums.commentcamarche.net/forum/affich-21955361-excel-valeur-condition
j'espère que vous avez enfin choisi entre les 2 réponses proposées.
Un commentaire serait en tout cas le bienvenue pour ne pas nous laisser l'impression d'avoir travaillé pour rien.