Formule sous excel

Résolu/Fermé
lzen Messages postés 333 Date d'inscription dimanche 21 octobre 2007 Statut Membre Dernière intervention 16 septembre 2022 - 22 avril 2011 à 15:02
lzen Messages postés 333 Date d'inscription dimanche 21 octobre 2007 Statut Membre Dernière intervention 16 septembre 2022 - 22 avril 2011 à 15:25
Bonjour,

J'ai créé un tableau sous excel comportant 9408 lignes. Maintenant il faut que j'attribus a chaque ligne le nom d'une personne. 10 personnes. Si je met 1 dans une colonne je veux avoir un nom qui apparait, si je met 4 jeveux un autre nom. Comment puis-je faire pour faire?


3 réponses

tu te crées une zone de données quelque part (le mieux c'est de le mettre sur un autre feuille)
La tu fais 2 colonnes:
A B
1 Pierre
2 Paul
3 Jacques
4 David


Dans la cellule où tu veux que le résultat s'affiche, tu mets la formule =recherchev(

ta plage source est la zone de données, ton critère c'est la cellule où tu as mis les 1 ou 4 ou .... la cible c'est 1 (premier index), valeur proche -> tu mets 0

Ensuite tu descends ta formule jusqu'en bas de ta feuille pour qu'elle s'applique à tout le tableau

Enfin, si tu n'as plus besoin de changer les noms, tu copie-colle les valeur uniquement dans une colonne finale, ainsi Excel ne va pas recalculer tous les recherchev à chaque mise à jour de la feuille ^^
0
Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 304
22 avril 2011 à 15:20
Bonjour
exemple à adapter:
votre liste de 9408 lignes en colonne A à partir de A2
votre liste de nom à remplir en colonne C
hors champ, par exemple de F1 à F10 entrez les N° 1à10
de ligne avec ces numéros, en G1 à G10, les noms correspondants
en D2 la formule:
=RECHERCHEV(C2;$F$1:$G$10;2;0)
vous donnera le nom correspondant au N° que vous placerez en C
tirez cette formule sur la hauteur du champ

si ensuite vous voulez figer le résultat
copier colonne C / Collage spécial valeur sur colonne B

crdlmnt
0
lzen Messages postés 333 Date d'inscription dimanche 21 octobre 2007 Statut Membre Dernière intervention 16 septembre 2022 10
22 avril 2011 à 15:25
C'est bon merci, c'est nikel.
0