[PostgreSQL] Problème d'installation

Fermé
Mougeole
Messages postés
34
Date d'inscription
vendredi 11 novembre 2005
Statut
Membre
Dernière intervention
7 octobre 2006
- 12 avril 2006 à 11:07
 mouss4rs - 26 oct. 2007 à 14:00
Bonjour
Je dois installer postgreSQL sur un serveur linux.
J'ai suivi les instructions de https://beuss.developpez.com/tutoriels/postgres/install/
J'ai un problème lorsque je veux compiler. Quand je lance le script ./configure j'ai le message d'erreur suivant :
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

Pourriez-vous m'aider à résoudre ce problème afin que je puisse enfin installer PostgreSQL?
Merci d'avance

Mougeole

5 réponses

maily
Messages postés
7554
Date d'inscription
lundi 26 juin 2000
Statut
Contributeur
Dernière intervention
13 août 2018
451
12 avril 2006 à 11:19
Bonjour!

Il me semble que tu n'as pas installé de compilateur C sur ta machine! ça fait parti des prérequis:

Vous aurez bien sûr également besoin d'un environnement de compilation complet (gcc, configure & Cie). Il est fort possible que cet environnement soit déjà présent sur votre système.

à vérifier!
0
Mougeole
Messages postés
34
Date d'inscription
vendredi 11 novembre 2005
Statut
Membre
Dernière intervention
7 octobre 2006
26
12 avril 2006 à 17:06
j'ai vérifier :

il y a bien un compilateur C sur la machine.

Quand je fait locate gcc

il me répond

/usr/share/ghostscript/Resource/CMap/HKgccs-B5-H

/usr/share/ghostscript/Resource/CMap/HKgccs-B5-V

/usr/share/ghostscript/Resource/ac14/CMap/HKgcc-B5-H

/usr/share/ghostscript/Resource/ac14/CMap/HKgcc-B5-V

/usr/lib/perl5/5.8.3/i386-linux-thread-multi/linux/compiler-gcc+.ph

/usr/lib/perl5/5.8.3/i386-linux-thread-multi/linux/compiler-gcc.ph

/usr/lib/perl5/5.8.3/i386-linux-thread-multi/linux/compiler-gcc2.ph

/usr/lib/perl5/5.8.3/i386-linux-thread-multi/linux/compiler-gcc3.ph

/usr/lib/gcc-lib

/usr/lib/gcc-lib/i586-mandrake-linux-gnu

/usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.3.2

/usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.3.2/ccl

/usr/X11R6/man/man1/gccmakedep.1x.bz2

/usr/java/j2re1.4.2_05/plugin/i386/ns610-gcc32

/usr/java/j2re1.4.2_05/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

/lib/libgcc_s-3.3.2.so.1

/lib/libgcc_s.so.1


Quand je fait un echo $PATH
il me répond

/bin:/usr/bin:/usr/local/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/home/postgres/bin

Voilà

Comment faire en sorte que la variable PATH pointe sur gcc?

Merci d'avance

Mougeole
0
Mougeole
Messages postés
34
Date d'inscription
vendredi 11 novembre 2005
Statut
Membre
Dernière intervention
7 octobre 2006
26
16 avril 2006 à 18:27
Salut

Bon depuis la dernière fois j'ai explorer quelques piste.

La dernière idée que je pivilégie c'est d'installer Postgres en .rpm plutôt que l'archive en .tar.gz

On verra bien...
0
Mougeole
Messages postés
34
Date d'inscription
vendredi 11 novembre 2005
Statut
Membre
Dernière intervention
7 octobre 2006
26
18 avril 2006 à 10:31
Salut

J'ai installer un compilateur c

j'ai installer :

gcc-cpp-3.4.3-7mdk.i586.rpm

glibc-2.3.4-8mdk.i586.rpm

gcc-3.4.3-7mdk.i586.rpm

Quand je fais un locate gcc je trouve, en plus des chemins précités, le chemin /usr/bin/gcc

Quand je fait un echo $PATH
j'ai bien /usr/bin dans ma variable d'environnement.

et quand je lance mon script ./configure j'ai toujours la même erreur : configure : error : no acceptable C compiler found in $PATH

est-ce que queslqu'un connait une solution?

Merci d'avance

Mougeole
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Bonjour,
j'ai le meme probleme, quelqu'un aurait-il trouver une solution
ou est ce quelqu'un sait comment installer postgres sur windows?

merci d'avance:-)
0