Travaux entre 2 onglets excel

Résolu/Fermé
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021 - 8 avril 2011 à 16:20
tontong Messages postés 2529 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 16 décembre 2022 - 15 avril 2011 à 15:18
Bonjour,

Je souhaite obtenir une valeur d'après plusieurs conditions entre deux onglets:

Feuil1

Cellule A1 = date xx/xx/xxxx
Colonne A = Nom prénom
Colonne C = Activité
Colonne D = Mesure
Colonne E = résultat

Feuil 2

Colonne H = Nom
Colonne J = résultat
exemple : en J2 (feuil2), je souhaite récupérer le résultat (Feuil1 Colonne E) à condition que la date et le nom soit identique.

Si cellule a1 (feuil1) = date cellule j1 (feuil2) et si le nom dans la colonne A (il faut extraire) = Nom cellule H2 (feuil2) alors récupérer valeur colonne E correspondante (feuil1) dans la feuil 2 cellule J2.

Feuil 1

en A1= 01/03/2011
Colonne A (à partir de A2).....
TOTO Gilles
TITI DURAND Marc
Tata Carole

Feuil 2

en J1 Mars 2011 (01/03/2011)
en H2 = TOTO
en J2 = résultat recherché

J'espère que je suis assez clair...

Merci d'avance,
Pygos



A voir également:

3 réponses

PtiSwiss Messages postés 96 Date d'inscription lundi 23 octobre 2006 Statut Membre Dernière intervention 6 mai 2011 37
8 avril 2011 à 16:27
bonjour

ca devrais donner quelque chose comme ça

=SI(ET(Feuil1!A1=Feuil2!J1;Feuil1!A2=Feuil2!H2);Feuil1!H2;"")

à voir après avec le nom des onglets et le numéro des cellules ou j'ai peut être fais une erreur
0
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021
Modifié par pygos le 8/04/2011 à 16:44
Merci, j'y suis presque, je souhaiterais trouver le nom dans la colonne sans préciser la cellule et si toutes les conditions sont remplies récupérer à partir du nom le résultat dans la colonne E ....

Ma formule après l'aide ...=SI(ET('Listing mois OSCARR'!A1=RECAPRODUCTION!P1;'Listing mois OSCARR'!A184=RECAPRODUCTION!H2);'Listing mois OSCARR'!E184;"")

Peut-être recherchev() , ce n'est pas ma spécialité....

Merci d'avance ,

Pygos
0
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021
15 avril 2011 à 11:36
En nommant les colonnes, j'ai essayé ceci mais cela ne fonctionne pas....

=SOMMEPROD(('OSCARR 03'!A1=P1)*(NOM=G2)*(ACTIVITE=H2)*(MESURE=I2))*(MESURE)


Les colonnes nommés sont sur la 1ère feuille...

Je devrais normalement obtenir 23,83...
0
tontong Messages postés 2529 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 16 décembre 2022 1 043
8 avril 2011 à 17:51
Bonjour,
En J2 de la feuil2 on peut entrer une des deux formules:
=SI(ET(Feuil1!$A$1=Feuil2!$J$1;Feuil2!H2<>"";GAUCHE(Feuil1!A2;NBCAR(Feuil2!H2))=Feuil2!H2);Feuil1!E2;"")
ou:
=SI(ET(Feuil1!$A$1=Feuil2!$J$1;Feuil2!H2<>"";EXACT(GAUCHE(Feuil1!A2;NBCAR(Feuil2!H2));Feuil2!H2));Feuil1!E2;"")
selon que l'on veut,ou non, le respect de la casse sur le nom.
Je vous laisse le soin de remplacer les noms des feuilles.
0
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021
Modifié par pygos le 14/04/2011 à 18:39
Bonjour,

C'est moi qui ne suis pas assez clair .....

Voici les conditions que j'essaye de définir .....

condition 1 : si la date en a1 feuil1 est égal à date en P1 feuil2
et
condition 2 : si le nom en colonne A feuil1est égal au nom en G2 feuil2
et
condition 3 : si l'activité en colonne C feuil1est égal à l'activite en H2 feuil2
et
condition 4 : si la mesure en colonne D feuil1est égal à la mesure en I2 feuil2
alors
récupérer l'information dans la colonne E feuil1 en P2 feuil2.

exemple feuil1
Col A / Col B / Col C / Col D / Col E
01/03/2011
Nom agent / Code agent / Activité Mesure / Prod Agent
TOTO / 10000 / PRN / Temps de production en heures / 18
TOTO / 10000 / PRN / Nombre de PRN traitées / 429
TOTO / 10000 / PRN / Prod glob / 23,83
TOTO / 10000 / PRN / Productivité agent minimum
TOTO / 10000 / PRN / Productivité agent moyenne
TOTO / 10000 / PRN / Productivité agent maximum

exemple feuil2

Col G Col H Col I Col J Col K Col L Col M Col N Col O Col P RECAP / / sept-10 / oct-10 / nov-10 /déc-10 /janv-11/févr-11 /mars-11

TOTO / PRN / Prod glob / / / / / / /23,83

Si toutes les conditions sont remplies en P2 devrait apparaitre 23,83.

Une macro serait peut être préférable ?

Merci d'avance,
pygos
0
tontong Messages postés 2529 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 16 décembre 2022 1 043
14 avril 2011 à 18:49
Bonjour,
Si vous pouviez nous transmettre un bout du fichier sans données confidentielles ce serait nettement plus clair.
Aller sur un site comme https://www.cjoint.com/ ou http://cijoint.fr/
Déposer le fichier.
Créer le lien.
Copier le lien dans le prochain message.
0
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021
Modifié par pygos le 15/04/2011 à 11:37
Merci d'avance !

http://www.cijoint.fr/cjlink.php?file=cj201104/cij6cQSXLQ.xls

En nommant les colonnes, j'ai essayé ceci mais cela ne fonctionne pas....

=SOMMEPROD(('OSCARR 03'!A1=P1)*(NOM=G2)*(ACTIVITE=H2)*(MESURE=I2))*(MESURE)


Les colonnes nommés sont sur la 1ère feuille...

Je devrais normalement obtenir 23,83...


Cordialement,
0
tontong Messages postés 2529 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 16 décembre 2022 1 043
15 avril 2011 à 14:25
Bonjour,
À condition d'entrer les bonnes valeurs en H2 et J2
=SI(O1='OSCARR 03'!A1;SOMMEPROD(('OSCARR 03'!A3:A2000=$G2)*('OSCARR 03'!C3:C2000=$H2)*('OSCARR 03'!D3:D2000=$J2)*('OSCARR 03'!E3:E2000));"")
Attention cependant car en cas de doublon dans la base SommeProd va effectuer le total.
0
pygos Messages postés 185 Date d'inscription vendredi 5 septembre 2008 Statut Membre Dernière intervention 3 mars 2021
15 avril 2011 à 14:57
Merci !!
0
tontong Messages postés 2529 Date d'inscription mercredi 3 février 2010 Statut Membre Dernière intervention 16 décembre 2022 1 043
15 avril 2011 à 15:18
Il serait plus judicieux d'utiliser une formule matricielle du genre:
=SI(A1=O1;INDEX($E$3:$E$35;EQUIV(1;($A$3:$A$35=$F$3)*($C$3:$C$35=$F$4)*($D$3:$D$35=$F$5);0));"")
À adapter avec les bonnes références.
0